summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorEric Le Bihan <eric.le.bihan.dev@free.fr>2014-07-25 17:31:41 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-26 09:15:23 +0200
commit2a86ff3bbd0f6982180a2f52f626f0fa22915310 (patch)
tree0758ec6e3c16afb32cd93224c4204a289290c432 /package
parentd1d119c271b1070e189beb06380540308e5d31ed (diff)
downloadbuildroot-2a86ff3bbd0f6982180a2f52f626f0fa22915310.tar.gz
buildroot-2a86ff3bbd0f6982180a2f52f626f0fa22915310.zip
systemd: add hook to disable ldconfig.service
Since version 215, systemd installs a service to execute /sbin/ldconfig when the sysinit target is reached. Unfortunately, /sbin/ldconfig is not installed on a target built using a glibc-based toolchain. As this service is not mandatory, it is now disabled, thus avoiding a warning in the journal. Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/systemd/systemd.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index a5e1bd465e..125b2fd7c4 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -149,10 +149,17 @@ define SYSTEMD_SANITIZE_PATH_IN_UNITS
-exec $(SED) 's,$(HOST_DIR),,g' {} \;
endef
+# Disable ldconfig.service, as /sbin/ldconfig is not available when the
+# target is built with a glibc-based toolchain.
+define SYSTEMD_DISABLE_LDCONFIG_SERVICE_HOOK
+ rm -f $(TARGET_DIR)/lib/systemd/system/sysinit.target.wants/ldconfig.service
+endef
+
SYSTEMD_POST_INSTALL_TARGET_HOOKS += \
SYSTEMD_INSTALL_INIT_HOOK \
SYSTEMD_INSTALL_MACHINEID_HOOK \
SYSTEMD_INSTALL_RESOLVCONF_HOOK \
+ SYSTEMD_DISABLE_LDCONFIG_SERVICE_HOOK \
SYSTEMD_SANITIZE_PATH_IN_UNITS
define SYSTEMD_USERS
OpenPOWER on IntegriCloud