summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-02-05 10:44:03 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-05 12:10:35 +0100
commit26aef889f1df32d5a15cd70f6b1e316ebb830cb7 (patch)
tree9baed5f64e8c19f89bd2f723353f2fa5b54b9486 /package
parentac57c640c6e2d605f25d150bdede17f6f94edd76 (diff)
downloadbuildroot-26aef889f1df32d5a15cd70f6b1e316ebb830cb7.tar.gz
buildroot-26aef889f1df32d5a15cd70f6b1e316ebb830cb7.zip
infra: remove unused 4th parameter to package infrastructures (pkgparentdir)
The fourth parameter to inner-generic-package is no longer used. Removing this parameters requires renaming all usages of $(5) to $(4), and updating the calls to inner-generic-package (and equivalent for the other package infrastructures). Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package')
-rw-r--r--package/pkg-autotools.mk13
-rw-r--r--package/pkg-cmake.mk13
-rw-r--r--package/pkg-generic.mk21
-rw-r--r--package/pkg-luarocks.mk7
-rw-r--r--package/pkg-python.mk17
5 files changed, 33 insertions, 38 deletions
diff --git a/package/pkg-autotools.mk b/package/pkg-autotools.mk
index 0ddfc6be06..cfbdc27161 100644
--- a/package/pkg-autotools.mk
+++ b/package/pkg-autotools.mk
@@ -48,8 +48,7 @@ endef
# for host packages
# argument 3 is the uppercase package name, without the HOST_ prefix
# for host packages
-# argument 4 is the package directory prefix
-# argument 5 is the type (target or host)
+# argument 4 is the type (target or host)
################################################################################
define inner-autotools-package
@@ -94,7 +93,7 @@ $(2)_INSTALL_TARGET_OPT ?= DESTDIR=$$(TARGET_DIR) install
# packages.
#
ifndef $(2)_CONFIGURE_CMDS
-ifeq ($(5),target)
+ifeq ($(4),target)
# Configure package for target
define $(2)_CONFIGURE_CMDS
@@ -220,7 +219,7 @@ endif
# file.
#
ifndef $(2)_BUILD_CMDS
-ifeq ($(5),target)
+ifeq ($(4),target)
define $(2)_BUILD_CMDS
$$(TARGET_MAKE_ENV) $$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) $$($$(PKG)_MAKE_OPT) -C $$($$(PKG)_SRCDIR)
endef
@@ -267,7 +266,7 @@ endif
# Call the generic package infrastructure to generate the necessary
# make targets
-$(call inner-generic-package,$(1),$(2),$(3),$(4),$(5))
+$(call inner-generic-package,$(1),$(2),$(3),$(4))
endef
@@ -275,5 +274,5 @@ endef
# autotools-package -- the target generator macro for autotools packages
################################################################################
-autotools-package = $(call inner-autotools-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),target)
-host-autotools-package = $(call inner-autotools-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),host)
+autotools-package = $(call inner-autotools-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),target)
+host-autotools-package = $(call inner-autotools-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),host)
diff --git a/package/pkg-cmake.mk b/package/pkg-cmake.mk
index 36283f07c0..dbe0d97c9a 100644
--- a/package/pkg-cmake.mk
+++ b/package/pkg-cmake.mk
@@ -31,8 +31,7 @@
# for host packages
# argument 3 is the uppercase package name, without the HOST_ prefix
# for host packages
-# argument 4 is the package directory prefix
-# argument 5 is the type (target or host)
+# argument 4 is the type (target or host)
################################################################################
define inner-cmake-package
@@ -55,7 +54,7 @@ $(2)_BUILDDIR = $$($(2)_SRCDIR)
# packages.
#
ifndef $(2)_CONFIGURE_CMDS
-ifeq ($(5),target)
+ifeq ($(4),target)
# Configure package for target
define $(2)_CONFIGURE_CMDS
@@ -99,7 +98,7 @@ $(2)_DEPENDENCIES += host-cmake
# file.
#
ifndef $(2)_BUILD_CMDS
-ifeq ($(5),target)
+ifeq ($(4),target)
define $(2)_BUILD_CMDS
$(TARGET_MAKE_ENV) $$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) $$($$(PKG)_MAKE_OPT) -C $$($$(PKG)_BUILDDIR)
endef
@@ -142,7 +141,7 @@ endif
# Call the generic package infrastructure to generate the necessary
# make targets
-$(call inner-generic-package,$(1),$(2),$(3),$(4),$(5))
+$(call inner-generic-package,$(1),$(2),$(3),$(4))
endef
@@ -150,8 +149,8 @@ endef
# cmake-package -- the target generator macro for CMake packages
################################################################################
-cmake-package = $(call inner-cmake-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),target)
-host-cmake-package = $(call inner-cmake-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),host)
+cmake-package = $(call inner-cmake-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),target)
+host-cmake-package = $(call inner-cmake-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),host)
################################################################################
# Generation of the CMake toolchain file
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 5778c5ca56..555c3c2e26 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -241,8 +241,7 @@ $(BUILD_DIR)/%/.stamp_dircleaned:
# for host packages
# argument 3 is the uppercase package name, without the HOST_ prefix
# for host packages
-# argument 4 is the package directory prefix
-# argument 5 is the type (target or host)
+# argument 4 is the type (target or host)
################################################################################
define inner-generic-package
@@ -254,7 +253,7 @@ define inner-generic-package
# these informations have only to be specified once, for both the
# target and host packages of a given .mk file.
-$(2)_TYPE = $(5)
+$(2)_TYPE = $(4)
$(2)_NAME = $(1)
$(2)_RAWNAME = $(patsubst host-%,%,$(1))
@@ -534,7 +533,7 @@ ifeq ($$($(2)_REDISTRIBUTE),YES)
ifneq ($$($(2)_SITE_METHOD),local)
ifneq ($$($(2)_SITE_METHOD),override)
# Packages that have a tarball need it downloaded and extracted beforehand
-$(1)-legal-info: $(1)-extract $(REDIST_SOURCES_DIR_$(call UPPERCASE,$(5)))
+$(1)-legal-info: $(1)-extract $(REDIST_SOURCES_DIR_$(call UPPERCASE,$(4)))
$(2)_MANIFEST_TARBALL = $$($(2)_SOURCE)
endif
endif
@@ -558,23 +557,23 @@ else
# Save license files if defined
ifeq ($(call qstrip,$$($(2)_LICENSE_FILES)),)
- @$(call legal-license-nofiles,$$($(2)_RAWNAME),$(call UPPERCASE,$(5)))
+ @$(call legal-license-nofiles,$$($(2)_RAWNAME),$(call UPPERCASE,$(4)))
@$(call legal-warning-pkg,$$($(2)_RAWNAME),cannot save license ($(2)_LICENSE_FILES not defined))
else
# Double dollar signs are really needed here, to catch host packages
# without explicit HOST_FOO_LICENSE_FILES assignment, also in case they
# have multiple license files.
- @$$(foreach F,$$($(2)_LICENSE_FILES),$$(call legal-license-file,$$($(2)_RAWNAME),$$(F),$$($(2)_DIR)/$$(F),$(call UPPERCASE,$(5)))$$(sep))
+ @$$(foreach F,$$($(2)_LICENSE_FILES),$$(call legal-license-file,$$($(2)_RAWNAME),$$(F),$$($(2)_DIR)/$$(F),$(call UPPERCASE,$(4)))$$(sep))
endif # license files
ifeq ($$($(2)_REDISTRIBUTE),YES)
# Copy the source tarball (just hardlink if possible)
- @cp -l $(DL_DIR)/$$($(2)_SOURCE) $(REDIST_SOURCES_DIR_$(call UPPERCASE,$(5))) 2>/dev/null || \
- cp $(DL_DIR)/$$($(2)_SOURCE) $(REDIST_SOURCES_DIR_$(call UPPERCASE,$(5)))
+ @cp -l $(DL_DIR)/$$($(2)_SOURCE) $(REDIST_SOURCES_DIR_$(call UPPERCASE,$(4))) 2>/dev/null || \
+ cp $(DL_DIR)/$$($(2)_SOURCE) $(REDIST_SOURCES_DIR_$(call UPPERCASE,$(4)))
endif # redistribute
endif # other packages
- @$(call legal-manifest,$$($(2)_RAWNAME),$$($(2)_VERSION),$$($(2)_LICENSE),$$($(2)_MANIFEST_LICENSE_FILES),$$($(2)_MANIFEST_TARBALL),$(call UPPERCASE,$(5)))
+ @$(call legal-manifest,$$($(2)_RAWNAME),$$($(2)_VERSION),$$($(2)_LICENSE),$$($(2)_MANIFEST_LICENSE_FILES),$$($(2)_MANIFEST_TARBALL),$(call UPPERCASE,$(4)))
endif # ifneq ($(call qstrip,$$($(2)_SOURCE)),)
$(foreach hook,$($(2)_POST_LEGAL_INFO_HOOKS),$(call $(hook))$(sep))
@@ -617,8 +616,8 @@ endef # inner-generic-package
################################################################################
# In the case of target packages, keep the package name "pkg"
-generic-package = $(call inner-generic-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),target)
+generic-package = $(call inner-generic-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),target)
# In the case of host packages, turn the package name "pkg" into "host-pkg"
-host-generic-package = $(call inner-generic-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),host)
+host-generic-package = $(call inner-generic-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),host)
# :mode=makefile:
diff --git a/package/pkg-luarocks.mk b/package/pkg-luarocks.mk
index fdd26c750c..bdda022f07 100644
--- a/package/pkg-luarocks.mk
+++ b/package/pkg-luarocks.mk
@@ -28,8 +28,7 @@
# for host packages
# argument 3 is the uppercase package name, without the HOST_ prefix
# for host packages
-# argument 4 is the package directory prefix
-# argument 5 is the type (target or host)
+# argument 4 is the type (target or host)
################################################################################
define inner-luarocks-package
@@ -70,7 +69,7 @@ endif
# Call the generic package infrastructure to generate the necessary
# make targets
-$(call inner-generic-package,$(1),$(2),$(3),$(4),$(5))
+$(call inner-generic-package,$(1),$(2),$(3),$(4))
endef
@@ -78,5 +77,5 @@ endef
# luarocks-package -- the target generator macro for LuaRocks packages
################################################################################
-luarocks-package = $(call inner-luarocks-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),target)
+luarocks-package = $(call inner-luarocks-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),target)
# host-luarocks-package not supported
diff --git a/package/pkg-python.mk b/package/pkg-python.mk
index 9cfd8200f4..9b3c97af35 100644
--- a/package/pkg-python.mk
+++ b/package/pkg-python.mk
@@ -80,8 +80,7 @@ HOST_PKG_PYTHON_SETUPTOOLS_INSTALL_OPT = \
# for host packages
# argument 3 is the uppercase package name, without the HOST_ prefix
# for host packages
-# argument 4 is the package directory prefix
-# argument 5 is the type (target or host)
+# argument 4 is the type (target or host)
################################################################################
define inner-python-package
@@ -103,7 +102,7 @@ endif
# Distutils
ifeq ($$($(2)_SETUP_TYPE),distutils)
-ifeq ($(5),target)
+ifeq ($(4),target)
$(2)_BASE_ENV = $$(PKG_PYTHON_DISTUTILS_ENV)
$(2)_BASE_BUILD_TGT = build
$(2)_BASE_BUILD_OPT = $$(PKG_PYTHON_DISTUTILS_BUILD_OPT)
@@ -116,7 +115,7 @@ $(2)_BASE_INSTALL_OPT = $$(HOST_PKG_PYTHON_DISTUTILS_INSTALL_OPT)
endif
# Setuptools
else ifeq ($$($(2)_SETUP_TYPE),setuptools)
-ifeq ($(5),target)
+ifeq ($(4),target)
$(2)_BASE_ENV = $$(PKG_PYTHON_SETUPTOOLS_ENV)
$(2)_BASE_BUILD_TGT = build -x
$(2)_BASE_BUILD_OPT =
@@ -149,7 +148,7 @@ $(2)_DEPENDENCIES ?= $(filter-out host-python host-python-setuptools host-python
# runtime) and the python interpreter on the host (for
# compilation). However, host packages only need the python
# interpreter on the host.
-ifeq ($(5),target)
+ifeq ($(4),target)
$(2)_DEPENDENCIES += host-python python
else
$(2)_DEPENDENCIES += host-python
@@ -164,7 +163,7 @@ endif
ifeq ($$($(2)_SETUP_TYPE),setuptools)
ifneq ($(2),HOST_PYTHON_SETUPTOOLS)
$(2)_DEPENDENCIES += host-python-setuptools
-ifeq ($(5),target)
+ifeq ($(4),target)
$(2)_DEPENDENCIES += host-python-distutilscross
endif
endif
@@ -212,7 +211,7 @@ endif
# Call the generic package infrastructure to generate the necessary
# make targets
-$(call inner-generic-package,$(1),$(2),$(3),$(4),$(5))
+$(call inner-generic-package,$(1),$(2),$(3),$(4))
endef
@@ -220,5 +219,5 @@ endef
# python-package -- the target generator macro for Python packages
################################################################################
-python-package = $(call inner-python-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),target)
-host-python-package = $(call inner-python-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),host)
+python-package = $(call inner-python-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),target)
+host-python-package = $(call inner-python-package,host-$(pkgname),$(call UPPERCASE,host-$(pkgname)),$(call UPPERCASE,$(pkgname)),host)
OpenPOWER on IntegriCloud