summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRomain Perier <romain.perier@free-electrons.com>2016-07-12 11:30:19 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-15 15:06:40 +0200
commit1ec1fbbdbb97aa1c42c7cf97c927465aa645aec6 (patch)
tree27537f940a73d2f3912df57e6fab95674e58bbbe /package
parent255086f960440b9711971026fc4943fd6c0d4eb8 (diff)
downloadbuildroot-1ec1fbbdbb97aa1c42c7cf97c927465aa645aec6.tar.gz
buildroot-1ec1fbbdbb97aa1c42c7cf97c927465aa645aec6.zip
qt: add option for enabling the accessibility support
This adds an entry in the configuration menu in order to enable or disable the accessibility support. Signed-off-by: Romain Perier <romain.perier@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/qt/Config.in5
-rw-r--r--package/qt/qt.mk7
2 files changed, 11 insertions, 1 deletions
diff --git a/package/qt/Config.in b/package/qt/Config.in
index 0fa2424842..548d180636 100644
--- a/package/qt/Config.in
+++ b/package/qt/Config.in
@@ -302,6 +302,11 @@ config BR2_PACKAGE_QT_QTTIFF
bool "Use Qt bundled libtiff"
endchoice
+config BR2_PACKAGE_QT_ACCESSIBILITY
+ bool "Enable accessibility support"
+ help
+ This enables and compiles the accessibility support.
+
endif # BR2_PACKAGE_QT_GUI_MODULE
choice
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index d56fe7e2e8..47d5b007f0 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -258,6 +258,12 @@ else
QT_CONFIGURE_OPTS += -no-libmng
endif
+ifeq ($(BR2_PACKAGE_QT_ACCESSIBILITY),y)
+QT_CONFIGURE_OPTS += -accessibility
+else
+QT_CONFIGURE_OPTS += -no-accessibility
+endif
+
ifeq ($(BR2_PACKAGE_QT_QTZLIB),y)
QT_CONFIGURE_OPTS += -qt-zlib
else
@@ -520,7 +526,6 @@ define QT_CONFIGURE_CMDS
-no-xinerama \
-no-cups \
-no-nis \
- -no-accessibility \
-no-separate-debug-info \
-prefix /usr \
-plugindir /usr/lib/qt/plugins \
OpenPOWER on IntegriCloud