summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-07 18:17:13 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-07 18:17:13 +0100
commit19bb96f0767751a0500062fcbee8450cd5fe3825 (patch)
tree11f13c211a071b355e43741386aee1ae34a30747 /package
parentd42de84a8f48cf10b832425a7506f44e2f2d9c8f (diff)
downloadbuildroot-19bb96f0767751a0500062fcbee8450cd5fe3825.tar.gz
buildroot-19bb96f0767751a0500062fcbee8450cd5fe3825.zip
squeezelite: reformat existing patch as a Git formatted patch
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/squeezelite/0001-Makefile-allow-passing-CFLAGS-and-LDFLAGS.patch (renamed from package/squeezelite/0001-Makefile-override.patch)20
1 files changed, 16 insertions, 4 deletions
diff --git a/package/squeezelite/0001-Makefile-override.patch b/package/squeezelite/0001-Makefile-allow-passing-CFLAGS-and-LDFLAGS.patch
index 4e1154176f..2f002a80bc 100644
--- a/package/squeezelite/0001-Makefile-override.patch
+++ b/package/squeezelite/0001-Makefile-allow-passing-CFLAGS-and-LDFLAGS.patch
@@ -1,12 +1,21 @@
+From a0f2e79d1373967dac9f3df4c500a71cd1b96b2b Mon Sep 17 00:00:00 2001
+From: Hiroshi Kawashima <kei-k@ca2.so-net.ne.jp>
+Date: Sun, 7 Feb 2016 18:04:53 +0100
+Subject: [PATCH] Makefile: allow passing CFLAGS and LDFLAGS
+
This patch is applied to squeezelite Makefile to add override
directive for CFLAGS and LDFLAGS assignment.
This enables adding flags to CFLAGS and LDFLAGS in Makefile.
Signed-off-by: Hiroshi Kawashima <kei-k@ca2.so-net.ne.jp>
+---
+ Makefile | 12 +++++++-----
+ 1 file changed, 7 insertions(+), 5 deletions(-)
-diff -ruN a/Makefile b/Makefile
---- a/Makefile 2015-02-01 23:56:21.000000000 +0900
-+++ b/Makefile 2015-09-29 20:06:52.268069187 +0900
+diff --git a/Makefile b/Makefile
+index dca2abd..286c725 100644
+--- a/Makefile
++++ b/Makefile
@@ -1,4 +1,6 @@
# Cross compile support - create a Makefile which defines these three variables and then includes this Makefile...
+override CFLAGS += $(OPTS)
@@ -14,7 +23,7 @@ diff -ruN a/Makefile b/Makefile
CFLAGS ?= -Wall -fPIC -O2 $(OPTS)
LDFLAGS ?= -lasound -lpthread -lm -lrt
EXECUTABLE ?= squeezelite
-@@ -52,20 +54,20 @@
+@@ -52,20 +54,20 @@ endif
# add optional link options
ifneq (,$(findstring $(OPT_LINKALL), $(CFLAGS)))
@@ -40,3 +49,6 @@ diff -ruN a/Makefile b/Makefile
endif
endif
+--
+2.6.4
+
OpenPOWER on IntegriCloud