summaryrefslogtreecommitdiffstats
path: root/package/zxing
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-09-27 21:32:38 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-04 15:07:23 +0200
commit0518a98ac3e715a846dfb72fcfb2ec7aed423084 (patch)
treeff1b926c857b43bedc1d6eb96c149d5a026e8e6a /package/zxing
parentbe47b84c1a5604e3f1bf831b011c6717a2900282 (diff)
downloadbuildroot-0518a98ac3e715a846dfb72fcfb2ec7aed423084.tar.gz
buildroot-0518a98ac3e715a846dfb72fcfb2ec7aed423084.zip
packages: rename FOO_MAKE_OPT into FOO_MAKE_OPTS
While the autotools infrastructure was using FOO_MAKE_OPT, generic packages were typically using FOO_MAKE_OPTS. This inconsistency becomes a problem when a new infrastructure is introduced that wants to make use of FOO_MAKE_OPT(S), and can live alongside either generic-package or autotools-package. The new infrastructure will have to choose between either OPT or OPTS, and thus rule out transparent usage by respectively generic packages or generic packages. An example of such an infrastructure is kconfig-package, which provides kconfig-related make targets. The OPTS variant is more logical, as there are typically multiple options. This patch renames all occurrences of FOO_MAKE_OPT in FOO_MAKE_OPTS. Sed command used: find * -type f | xargs sed -i 's#_MAKE_OPT\>#&S#g' Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/zxing')
-rw-r--r--package/zxing/zxing.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/zxing/zxing.mk b/package/zxing/zxing.mk
index 5942167fde..7d30cc3a1f 100644
--- a/package/zxing/zxing.mk
+++ b/package/zxing/zxing.mk
@@ -17,7 +17,7 @@ ZXING_DEPENDENCIES += libiconv
else
# There is no locale support in the toolchain and libiconv
# is not available so disable iconv support in zxing
-ZING_MAKE_OPT=CXXFLAGS+="-DNO_ICONV"
+ZING_MAKE_OPTS=CXXFLAGS+="-DNO_ICONV"
endif
endif
@@ -26,7 +26,7 @@ define ZXING_EXTRACT_CMDS
endef
define ZXING_BUILD_CMDS
- $(MAKE) -C $(@D)/cpp/core/src $(TARGET_CONFIGURE_OPTS) $(ZING_MAKE_OPT)
+ $(MAKE) -C $(@D)/cpp/core/src $(TARGET_CONFIGURE_OPTS) $(ZING_MAKE_OPTS)
endef
define ZXING_INSTALL_STAGING_CMDS
OpenPOWER on IntegriCloud