summaryrefslogtreecommitdiffstats
path: root/package/zeromq/zeromq.mk
diff options
context:
space:
mode:
authorLionel Orry <lionel.orry@gmail.com>2015-04-22 09:58:56 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-22 22:14:00 +0200
commit1d2448e46d48809e110cf0d347dd5c845c20eaa7 (patch)
treef51f8957a0584e5aaca13dc27a641035e0081c51 /package/zeromq/zeromq.mk
parente7035d4eb90652428cdd4f108f890d57f548d387 (diff)
downloadbuildroot-1d2448e46d48809e110cf0d347dd5c845c20eaa7.tar.gz
buildroot-1d2448e46d48809e110cf0d347dd5c845c20eaa7.zip
package/zeromq: enable kernel-based feature flags
The current configuration system does not check for cached variables for these flags, and thus they are always disabled when cross-compiling. This patch fixes the configuration system to use cached variables and enables them at configuration time. Signed-off-by: Lionel Orry <lionel.orry@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/zeromq/zeromq.mk')
-rw-r--r--package/zeromq/zeromq.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/zeromq/zeromq.mk b/package/zeromq/zeromq.mk
index dbd6fc7da7..7e9ed19fe7 100644
--- a/package/zeromq/zeromq.mk
+++ b/package/zeromq/zeromq.mk
@@ -11,8 +11,18 @@ ZEROMQ_DEPENDENCIES = util-linux
ZEROMQ_LICENSE = LGPLv3+ with exceptions
ZEROMQ_LICENSE_FILES = COPYING COPYING.LESSER
# For 0001-tests-disable-test_fork-if-fork-is-not-available.patch
+# and 0002-acinclude.m4-make-kernel-specific-flags-cacheable.patch
ZEROMQ_AUTORECONF = YES
+# Assume these flags are always available. It is true, at least for
+# SOCK_CLOEXEC, since linux v2.6.27.
+# Note: the flag TCP_KEEPALIVE is NOT available so we do not include it.
+ZEROMQ_CONF_ENV = libzmq_cv_sock_cloexec=yes \
+ libzmq_cv_so_keepalive=yes \
+ libzmq_cv_tcp_keepcnt=yes \
+ libzmq_cv_tcp_keepidle=yes \
+ libzmq_cv_tcp_keepintvl=yes
+
# Only tools/curve_keygen.c needs this, but it doesn't hurt to pass it
# for the rest of the build as well (which automatically includes stdc++).
ifeq ($(BR2_STATIC_LIBS),y)
OpenPOWER on IntegriCloud