summaryrefslogtreecommitdiffstats
path: root/package/x264
diff options
context:
space:
mode:
authorDavid du Colombier <0intro@gmail.com>2014-10-09 10:41:24 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-10-11 13:22:52 +0200
commitae2c1f889883081e687e1b2cd59c08417232c0a8 (patch)
treecf326d4ee94c950edc9fa991584e2e47c89b6c62 /package/x264
parent7417616e09eab582accf73e2ec2f7cec9cef6cd6 (diff)
downloadbuildroot-ae2c1f889883081e687e1b2cd59c08417232c0a8.tar.gz
buildroot-ae2c1f889883081e687e1b2cd59c08417232c0a8.zip
x264: use assembly files on ARMv7
[Peter: use positive logic for ifeq, move ARM handling inside ifeq] Signed-off-by: David du Colombier <0intro@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/x264')
-rw-r--r--package/x264/x264.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/x264/x264.mk b/package/x264/x264.mk
index 35d9fef02a..ac8fe948a4 100644
--- a/package/x264/x264.mk
+++ b/package/x264/x264.mk
@@ -14,6 +14,10 @@ X264_INSTALL_STAGING = YES
ifeq ($(BR2_i386)$(BR2_x86_64),y)
X264_DEPENDENCIES += host-yasm
+else ifeq ($(BR2_cortex_a5)$(BR2_cortex_a7)$(BR2_cortex_a8)$(BR2_cortex_a9)$(BR2_cortex_a12)$(BR2_cortex_a15),y)
+# We need to pass gcc as AS, because the ARM assembly files have to be
+# preprocessed
+X264_CONF_ENV += AS="$(TARGET_CC)"
else
X264_CONF_OPTS += --disable-asm
endif
@@ -32,7 +36,7 @@ endif
# the configure script is not generated by autoconf
define X264_CONFIGURE_CMDS
- (cd $(@D); $(TARGET_CONFIGURE_OPTS) ./configure \
+ (cd $(@D); $(TARGET_CONFIGURE_OPTS) $(X264_CONF_ENV) ./configure \
--prefix=/usr \
--host="$(GNU_TARGET_NAME)" \
--cross-prefix="$(TARGET_CROSS)" \
OpenPOWER on IntegriCloud