summaryrefslogtreecommitdiffstats
path: root/package/rust-bin
diff options
context:
space:
mode:
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>2018-04-02 15:09:24 +0200
committerPeter Korsgaard <peter@korsgaard.com>2018-04-02 15:53:53 +0200
commit514291f39ef066cbe4dd9b41e1a3b0268fc8efb8 (patch)
tree3b5ddd54ca0e3583ddeeb4527f71e09472b712bb /package/rust-bin
parent9447e866187728009addf0cc62aa0c6b293b6dcd (diff)
downloadbuildroot-514291f39ef066cbe4dd9b41e1a3b0268fc8efb8.tar.gz
buildroot-514291f39ef066cbe4dd9b41e1a3b0268fc8efb8.zip
packages: use new $($PKG)_DL_DIR) variable
Instead of DL_DIR, the package should now use $(PKG)_DL_DIR to ease the transition into a new directory structure for DL_DIR. This commit has been generated with the following scripts: for i in $(find . -iname "*.mk"); do if ! grep -q "\$(DL_DIR)" ${i}; then continue fi pkg_name="$(basename $(dirname ${i}))" [ "${pkg_name}" = "package" ] && continue raw_pkg_name=$(echo ${pkg_name} | tr [a-z] [A-Z] | tr '-' '_') pkg_dl_dir="${raw_pkg_name}_DL_DIR" sed -i "s/\$(DL_DIR)/\$($pkg_dl_dir)/" ${i} done Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/rust-bin')
-rw-r--r--package/rust-bin/rust-bin.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/rust-bin/rust-bin.mk b/package/rust-bin/rust-bin.mk
index cd5844b115..759d468304 100644
--- a/package/rust-bin/rust-bin.mk
+++ b/package/rust-bin/rust-bin.mk
@@ -22,7 +22,7 @@ HOST_RUST_BIN_LIBSTD_HOST_PREFIX = rust-std-$(RUST_BIN_VERSION)-$(RUSTC_HOST_NAM
define HOST_RUST_BIN_LIBSTD_EXTRACT
mkdir -p $(@D)/std
$(foreach f,$(HOST_RUST_BIN_EXTRA_DOWNLOADS), \
- $(call suitable-extractor,$(f)) $(DL_DIR)/$(f) | \
+ $(call suitable-extractor,$(f)) $(RUST_BIN_DL_DIR)/$(f) | \
$(TAR) -C $(@D)/std $(TAR_OPTIONS) -
)
cd $(@D)/rustc/lib/rustlib; \
OpenPOWER on IntegriCloud