summaryrefslogtreecommitdiffstats
path: root/package/qt
diff options
context:
space:
mode:
authorJulien Boibessot <julien.boibessot@armadeus.com>2014-01-06 22:43:02 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-01-09 21:03:58 +0100
commit195235c9d9b3cb66392102cf292f31800765ca7a (patch)
tree9557391a82bc7490a8b708def4b08261c5efdc9c /package/qt
parent49cfa71e41e8d401cb4616c7f6bab2deafb5072e (diff)
downloadbuildroot-195235c9d9b3cb66392102cf292f31800765ca7a.tar.gz
buildroot-195235c9d9b3cb66392102cf292f31800765ca7a.zip
qt4: allow separate build/installation of demos and examples
Signed-off-by: Jeremie Scheer <jeremie.scheer@armadeus.com> Signed-off-by: Julien Boibessot <julien.boibessot@armadeus.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/qt')
-rw-r--r--package/qt/Config.in8
-rw-r--r--package/qt/qt.mk9
2 files changed, 14 insertions, 3 deletions
diff --git a/package/qt/Config.in b/package/qt/Config.in
index dd2b6d9ec9..926d54c619 100644
--- a/package/qt/Config.in
+++ b/package/qt/Config.in
@@ -21,7 +21,13 @@ config BR2_PACKAGE_QT_DEBUG
If unsure, say N.
config BR2_PACKAGE_QT_DEMOS
- bool "Compile and install demos and examples (with code)"
+ bool "Compile and install Qt demos (with code)"
+ select BR2_PACKAGE_QT_GUI_MODULE
+ help
+ If unsure, say N.
+
+config BR2_PACKAGE_QT_EXAMPLES
+ bool "Compile and install Qt examples (with code)"
select BR2_PACKAGE_QT_GUI_MODULE
help
If unsure, say N.
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 029d317974..867b79867c 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -59,9 +59,14 @@ QT_CONFIGURE_OPTS += -no-qt3support
endif
ifeq ($(BR2_PACKAGE_QT_DEMOS),y)
-QT_CONFIGURE_OPTS += -examplesdir $(TARGET_DIR)/usr/share/qt/examples -demosdir $(TARGET_DIR)/usr/share/qt/demos
+QT_CONFIGURE_OPTS += -demosdir $(TARGET_DIR)/usr/share/qt/demos
else
-QT_CONFIGURE_OPTS += -nomake examples -nomake demos
+QT_CONFIGURE_OPTS += -nomake demos
+endif
+ifeq ($(BR2_PACKAGE_QT_EXAMPLES),y)
+QT_CONFIGURE_OPTS += -examplesdir $(TARGET_DIR)/usr/share/qt/examples
+else
+QT_CONFIGURE_OPTS += -nomake examples
endif
# ensure glib is built first if enabled for Qt's glib support
OpenPOWER on IntegriCloud