summaryrefslogtreecommitdiffstats
path: root/package/qt5
diff options
context:
space:
mode:
authorFatih Aşıcı <fatih.asici@gmail.com>2014-01-02 09:07:02 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-01-02 15:04:16 +0100
commit467ea8c2ee1fbcd2be3eb638aabead8a5045ab35 (patch)
tree2f396c7034ed61160d11e065cf2c6908fc250446 /package/qt5
parent5cb4cd8ef39eb1b7879c1750da5fc1d8ec587012 (diff)
downloadbuildroot-467ea8c2ee1fbcd2be3eb638aabead8a5045ab35.tar.gz
buildroot-467ea8c2ee1fbcd2be3eb638aabead8a5045ab35.zip
qt5base: add an option to build and install examples
Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Tested-by: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5base/Config.in7
-rw-r--r--package/qt5/qt5base/qt5base.mk14
2 files changed, 20 insertions, 1 deletions
diff --git a/package/qt5/qt5base/Config.in b/package/qt5/qt5base/Config.in
index e932e240a4..3090d65a27 100644
--- a/package/qt5/qt5base/Config.in
+++ b/package/qt5/qt5base/Config.in
@@ -28,6 +28,13 @@ config BR2_PACKAGE_QT5BASE_LICENSE_APPROVED
See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
+config BR2_PACKAGE_QT5BASE_EXAMPLES
+ bool "Compile and install examples (with code)"
+ select BR2_PACKAGE_QT5BASE_NETWORK
+ select BR2_PACKAGE_QT5BASE_XML
+ help
+ If unsure, say N.
+
config BR2_PACKAGE_QT5BASE_NETWORK
bool "network module"
help
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index e46bdebe55..6928bb81ce 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -134,6 +134,8 @@ QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBGLIB2),libglib2)
QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_ICU),-icu,-no-icu)
QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_QT5BASE_ICU),icu)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_EXAMPLES),-make,-nomake) examples
+
# Build the list of libraries to be installed on the target
QT5BASE_INSTALL_LIBS_y += Qt5Core
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_NETWORK) += Qt5Network
@@ -162,8 +164,9 @@ define QT5BASE_CONFIGURE_CMDS
-headerdir /usr/include/qt5 \
-sysroot $(STAGING_DIR) \
-plugindir /usr/lib/qt/plugins \
+ -examplesdir /usr/lib/qt/examples \
-no-rpath \
- -nomake examples -nomake tests \
+ -nomake tests \
-device buildroot \
-device-option CROSS_COMPILE="$(CCACHE) $(TARGET_CROSS)" \
-device-option BUILDROOT_COMPILER_CFLAGS="$(TARGET_CFLAGS)" \
@@ -203,15 +206,24 @@ define QT5BASE_INSTALL_TARGET_FONTS
fi
endef
+define QT5BASE_INSTALL_TARGET_EXAMPLES
+ if [ -d $(STAGING_DIR)/usr/lib/qt/examples/ ] ; then \
+ mkdir -p $(TARGET_DIR)/usr/lib/qt/examples ; \
+ cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/* $(TARGET_DIR)/usr/lib/qt/examples ; \
+ fi
+endef
+
ifeq ($(BR2_PREFER_STATIC_LIB),y)
define QT5BASE_INSTALL_TARGET_CMDS
$(QT5BASE_INSTALL_TARGET_FONTS)
+ $(QT5BASE_INSTALL_TARGET_EXAMPLES)
endef
else
define QT5BASE_INSTALL_TARGET_CMDS
$(QT5BASE_INSTALL_TARGET_LIBS)
$(QT5BASE_INSTALL_TARGET_PLUGINS)
$(QT5BASE_INSTALL_TARGET_FONTS)
+ $(QT5BASE_INSTALL_TARGET_EXAMPLES)
endef
endif
OpenPOWER on IntegriCloud