summaryrefslogtreecommitdiffstats
path: root/package/python3
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-02-18 21:39:58 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-18 22:50:48 +0100
commita30f276a4a0af40fadf860f981fcae1ab74ab2c8 (patch)
tree9af5b35b69d589bc98274247b07376f5a56421be /package/python3
parenteebbd2d91935c4a87a51c19c5bd9a37e1f703483 (diff)
downloadbuildroot-a30f276a4a0af40fadf860f981fcae1ab74ab2c8.tar.gz
buildroot-a30f276a4a0af40fadf860f981fcae1ab74ab2c8.zip
python3: add python -> python3 symlink for the host variant
The target python3 depends on host-python3, but most of the scripts call "python", so we need to ensure that $(HOST_DIR)/usr/bin/python exists. This patch achieves this by creating a python -> python3 symbolic link in $(HOST_DIR), just like we are already doing for the target Python 3. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/python3')
-rw-r--r--package/python3/python3.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/python3/python3.mk b/package/python3/python3.mk
index d49fe4860b..ba72e75329 100644
--- a/package/python3/python3.mk
+++ b/package/python3/python3.mk
@@ -159,5 +159,11 @@ ifneq ($(BR2_PACKAGE_PYTHON),y)
PYTHON3_POST_INSTALL_TARGET_HOOKS += PYTHON3_INSTALL_SYMLINK
endif
+define HOST_PYTHON3_INSTALL_SYMLINK
+ ln -fs python3 $(HOST_DIR)/usr/bin/python
+endef
+
+HOST_PYTHON3_POST_INSTALL_HOOKS += HOST_PYTHON3_INSTALL_SYMLINK
+
$(eval $(autotools-package))
$(eval $(host-autotools-package))
OpenPOWER on IntegriCloud