summaryrefslogtreecommitdiffstats
path: root/package/python3/005-pyc-pyo-conditional.patch
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-12-01 23:22:51 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-12-01 23:24:07 +0100
commitcc257ee493bbf3261417908684dbff834d853ae6 (patch)
treecca896590d214d7bc90aad71fb8a76465438242b /package/python3/005-pyc-pyo-conditional.patch
parent2723fa4a5066b8820b4ff03e2912ccea9ea7c5e0 (diff)
parent01e3d2eff15eb2535c4c15eb4f62467a50fe6a5f (diff)
downloadbuildroot-cc257ee493bbf3261417908684dbff834d853ae6.tar.gz
buildroot-cc257ee493bbf3261417908684dbff834d853ae6.zip
Merge branch 'next'
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/python3/005-pyc-pyo-conditional.patch')
-rw-r--r--package/python3/005-pyc-pyo-conditional.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/python3/005-pyc-pyo-conditional.patch b/package/python3/005-pyc-pyo-conditional.patch
index c3b159da76..0d60ff6949 100644
--- a/package/python3/005-pyc-pyo-conditional.patch
+++ b/package/python3/005-pyc-pyo-conditional.patch
@@ -9,27 +9,27 @@ Index: b/Makefile.pre.in
+ifeq (@PYC_BUILD@,yes)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST) -f $(STDLIB_CACHE_FLAGS) \
+ -d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
+endif
+ifeq (@PYO_BUILD@,yes)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST) -f $(STDLIB_CACHE_FLAGS) \
+ -d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
+endif
+ifeq (@PYC_BUILD@,yes)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST)/site-packages -f $(STDLIB_CACHE_FLAGS) \
+ -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
+endif
+ifeq (@PYO_BUILD@,yes)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST)/site-packages -f $(STDLIB_CACHE_FLAGS) \
+ -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
+endif
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
OpenPOWER on IntegriCloud