summaryrefslogtreecommitdiffstats
path: root/package/python3/0024-Add-an-option-to-disable-decimal.patch
diff options
context:
space:
mode:
authorAndrey Smirnov <andrew.smirnov@gmail.com>2017-03-23 08:21:12 -0700
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-03-25 15:18:49 +0100
commitd2afa01f76ce2c7610286103340048d953b27e45 (patch)
tree5fffb2d070841068df535c03449c11a15e43318e /package/python3/0024-Add-an-option-to-disable-decimal.patch
parentf48f1a89a0c598ebefd2643af3ad6aff981e291c (diff)
downloadbuildroot-d2afa01f76ce2c7610286103340048d953b27e45.tar.gz
buildroot-d2afa01f76ce2c7610286103340048d953b27e45.zip
python3: Bump version to 3.6.1
Update all appropriate version numbers as well as SHAs and MD5s as well as repbasing BR's patches on top of 3.6.1 codebase (new github repo tree, v3.6.1 tag was used). Note that patch: [PATCH] Change the install location of _sysconfigdata.py was dropped due to the fact taht build system now adds platform specific suffix to sysconfigdata's name, so each platform's file should have a unique name and distutils now allows to specify which sysconfigdata is used via _PYTHON_SYSCONFIGDATA_NAME see: https://github.com/python/cpython/commit/c4b53afce491142b80b228a21a05de5dcfd8d36f https://github.com/python/cpython/commit/92dec548ff1494b86f08bd3753ca91a9330b4ea9 and patches: [PATCH] distutils/sysconfig: use sysconfigdata [PATCH] setup.py: do not add invalid header locations [PATCH] Do not harcode invalid path to ncursesw headers was dropped since it looks like it made it's way upstream, see: https://github.com/python/cpython/commit/409482251b06fe75c4ee56e85ffbb4b23d934159 https://github.com/python/cpython/commit/1351c31aa9651b278d7ef8ec79af3b646a520235 https://github.com/python/cpython/commit/e13c3201fb66c4c211b4ebb7604d1435bedc1015 respectively. Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python3/0024-Add-an-option-to-disable-decimal.patch')
-rw-r--r--package/python3/0024-Add-an-option-to-disable-decimal.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/package/python3/0024-Add-an-option-to-disable-decimal.patch b/package/python3/0024-Add-an-option-to-disable-decimal.patch
new file mode 100644
index 0000000000..27a24213a3
--- /dev/null
+++ b/package/python3/0024-Add-an-option-to-disable-decimal.patch
@@ -0,0 +1,62 @@
+From dc321780e26a9270f20b784f438a632bd952cbb3 Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Wed, 23 Dec 2015 11:51:31 +0100
+Subject: [PATCH] Add an option to disable decimal
+
+This patch replaces the existing --with-system-libmpdec option with a
+--with-libmpdec={system,builtin,none} option, which allows to tell
+Python whether we want to use the system libmpdec (already installed),
+the libmpdec builtin the Python sources, or no libmpdec at all.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ configure.ac | 17 ++++++++++++-----
+ setup.py | 2 +-
+ 2 files changed, 13 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 72989a1..71aea1d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2831,13 +2831,20 @@ AC_SUBST(LIBFFI_INCLUDEDIR)
+ AC_MSG_RESULT($with_system_ffi)
+
+ # Check for use of the system libmpdec library
+-AC_MSG_CHECKING(for --with-system-libmpdec)
+-AC_ARG_WITH(system_libmpdec,
+- AS_HELP_STRING([--with-system-libmpdec], [build _decimal module using an installed libmpdec library]),
++AC_MSG_CHECKING(for --with-libmpdec)
++AC_ARG_WITH(libmpdec,
++ AS_HELP_STRING([--with-libmpdec], [select which libmpdec version to use: system, builtin, none]),
+ [],
+- [with_system_libmpdec="no"])
++ [with_libmpdec="builtin"])
+
+-AC_MSG_RESULT($with_system_libmpdec)
++AC_MSG_RESULT($with_libmpdec)
++if test "$with_libmpdec" != "none"; then
++ MPDEC=yes
++else
++ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _decimal"
++ MPDEC=no
++fi
++AC_SUBST(MPDEC)
+
+ # Check for support for loadable sqlite extensions
+ AC_MSG_CHECKING(for --enable-loadable-sqlite-extensions)
+diff --git a/setup.py b/setup.py
+index 1079eba..c3a96c1 100644
+--- a/setup.py
++++ b/setup.py
+@@ -2055,7 +2055,7 @@ class PyBuildExt(build_ext):
+ def _decimal_ext(self):
+ extra_compile_args = []
+ undef_macros = []
+- if '--with-system-libmpdec' in sysconfig.get_config_var("CONFIG_ARGS"):
++ if '--with-libmpdec=system' in sysconfig.get_config_var("CONFIG_ARGS"):
+ include_dirs = []
+ libraries = [':libmpdec.so.2']
+ sources = ['_decimal/_decimal.c']
+--
+2.9.3
+
OpenPOWER on IntegriCloud