summaryrefslogtreecommitdiffstats
path: root/package/python/113-optional-zlib.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-28 21:54:55 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-02 19:30:25 +0100
commit897d07c313104ddb54fcf9c538acb0ca65e1a687 (patch)
tree6a92eaeced471ff0029b54d00b86ede1c8c4a18f /package/python/113-optional-zlib.patch
parent9badea2d058a75182f2a37bbefa0aaf48020575d (diff)
downloadbuildroot-897d07c313104ddb54fcf9c538acb0ca65e1a687.tar.gz
buildroot-897d07c313104ddb54fcf9c538acb0ca65e1a687.zip
python: rename patches to the new convention
Note that we don't use completely sequential numbers, because patches below 100 are used to address cross-compilation issues in Python, while patches above 100 are used to make more Python modules configurable. [Thomas: fixup commit log.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/python/113-optional-zlib.patch')
-rw-r--r--package/python/113-optional-zlib.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/python/113-optional-zlib.patch b/package/python/113-optional-zlib.patch
new file mode 100644
index 0000000000..a4ca8bd441
--- /dev/null
+++ b/package/python/113-optional-zlib.patch
@@ -0,0 +1,24 @@
+Add an option to disable the zlib module
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ configure.in | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+Index: b/configure.ac
+===================================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -2668,6 +2668,12 @@
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} bz2"
+ fi])
+
++AC_ARG_ENABLE(zlib,
++ AS_HELP_STRING([--disable-zlib], [disable ZLIB]),
++ [ if test "$enableval" = "no"; then
++ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} zlib"
++ fi])
++
+ AC_ARG_ENABLE(dbm,
+ AS_HELP_STRING([--disable-dbm], [disable DBM]),
+ [ if test "$enableval" = "no"; then
OpenPOWER on IntegriCloud