summaryrefslogtreecommitdiffstats
path: root/package/pulseaudio/pulseaudio.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-02 16:31:23 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-06 11:16:00 +0100
commit7290dc1e87b23fe21c75c50b2238004273a0ec5c (patch)
treeb56ae68e72f3fe42e287d2cb21b11f6f3f5fc5e3 /package/pulseaudio/pulseaudio.mk
parent8ea392b84e3a02a7827fc3b97b541d3c41c83935 (diff)
downloadbuildroot-7290dc1e87b23fe21c75c50b2238004273a0ec5c.tar.gz
buildroot-7290dc1e87b23fe21c75c50b2238004273a0ec5c.zip
pulseaudio: remove BR2_ARCH_HAS_ATOMICS dependency
pulseaudio is able to either use the atomic __sync builtins from the compiler, or to rely on libatomic_ops for atomic operations. However, since it anyway selects json-c which requires the __sync built-ins, it means using libatomic_ops is useless: even if you use libatomic_ops for pulseaudio, you'd still get a link error in pulseaudio due to the missing __sync built-in for the json-c library. Also, since pulseaudio now inherits the BR2_TOOLCHAIN_HAS_SYNC_4 from json-c, which matches the __sync built-in from pulseaudio, this commit: - Drops the BR2_ARCH_HAS_ATOMICS dependency - Forces pulseaudio to not detect libatomic_ops - Propagates the removal of BR2_ARCH_HAS_ATOMICS dependency to pulseaudio's reverse dependencies. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/pulseaudio/pulseaudio.mk')
-rw-r--r--package/pulseaudio/pulseaudio.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/pulseaudio/pulseaudio.mk b/package/pulseaudio/pulseaudio.mk
index 845009043a..86bbb2fe1e 100644
--- a/package/pulseaudio/pulseaudio.mk
+++ b/package/pulseaudio/pulseaudio.mk
@@ -15,9 +15,14 @@ PULSEAUDIO_CONF_OPTS = \
--disable-legacy-database-entry-format \
--disable-manpages
+# Make sure we don't detect libatomic_ops. Indeed, since pulseaudio
+# requires json-c, which needs 4 bytes __sync builtins, there should
+# be no need for pulseaudio to rely on libatomic_ops.
+PULSE_AUDIO_CONF_ENV += \
+ ac_cv_header_atomic_ops_h=no
+
PULSEAUDIO_DEPENDENCIES = \
host-pkgconf libtool json-c libsndfile speex host-intltool \
- $(if $(BR2_PACKAGE_LIBATOMIC_OPS),libatomic_ops) \
$(if $(BR2_PACKAGE_LIBSAMPLERATE),libsamplerate) \
$(if $(BR2_PACKAGE_ALSA_LIB),alsa-lib) \
$(if $(BR2_PACKAGE_LIBGLIB2),libglib2) \
OpenPOWER on IntegriCloud