summaryrefslogtreecommitdiffstats
path: root/package/polarssl/polarssl.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-10-27 11:07:18 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-27 17:49:13 +0100
commit130ca81bb28a3d842f6c99e7f3a6de35733df331 (patch)
tree92ddf696afef71bb19d4d2b618635eb9b2dd7ccf /package/polarssl/polarssl.mk
parentbeb20c5492f310e2971c14d1f1e56437ed554a46 (diff)
downloadbuildroot-130ca81bb28a3d842f6c99e7f3a6de35733df331.tar.gz
buildroot-130ca81bb28a3d842f6c99e7f3a6de35733df331.zip
polarssl: disable assembly for more scenarios
Disable assembly optimizations for: Microblaze in general (previously a patch). ARM with debugging in Thumb1/2 mode. This one fixes: http://autobuild.buildroot.net/results/31e/31e8c4e29d51039cd5d213c2fe176a9cc39879da/ Do so in a nicer way with a one-liner sed and drop the patch. And rename patches around, numbering was off. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/polarssl/polarssl.mk')
-rw-r--r--package/polarssl/polarssl.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/polarssl/polarssl.mk b/package/polarssl/polarssl.mk
index 7c2750518a..046c6bfd0c 100644
--- a/package/polarssl/polarssl.mk
+++ b/package/polarssl/polarssl.mk
@@ -14,4 +14,16 @@ POLARSSL_INSTALL_STAGING = YES
POLARSSL_LICENSE = GPLv2
POLARSSL_LICENSE_FILES = LICENSE
+define POLARSSL_DISABLE_ASM
+ $(SED) '/^#define POLARSSL_HAVE_ASM/d' $(@D)/include/polarssl/config.h
+endef
+
+# ARM in thumb mode breaks debugging with asm optimizations
+# Microblaze asm optimizations are broken in general
+ifeq ($(BR2_ENABLE_DEBUG)$(BR2_ARM_INSTRUCTIONS_THUMB)$(BR2_ARM_INSTRUCTIONS_THUMB2),yy)
+POLARSSL_POST_CONFIGURE_HOOKS += POLARSSL_DISABLE_ASM
+else ifeq ($(BR2_microblaze),y)
+POLARSSL_POST_CONFIGURE_HOOKS += POLARSSL_DISABLE_ASM
+endif
+
$(eval $(cmake-package))
OpenPOWER on IntegriCloud