summaryrefslogtreecommitdiffstats
path: root/package/pkg-rebar.mk
diff options
context:
space:
mode:
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>2015-07-14 13:36:25 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-14 18:08:23 +0200
commit7a6b83a211612ff95a1f5d35b2861ad5655ac8b1 (patch)
treeaca5004d46dc09c23c27e3fe207bd09bdb472fd7 /package/pkg-rebar.mk
parentc7ca4e81163700146e39f3b9aba90225bad86b45 (diff)
downloadbuildroot-7a6b83a211612ff95a1f5d35b2861ad5655ac8b1.tar.gz
buildroot-7a6b83a211612ff95a1f5d35b2861ad5655ac8b1.zip
skeleton: New package
Create a proper package for the skeleton. The main Makefile is modified to remove the skeleton support. The 'dirs' target, will create the $(TARGET_DIR). The file 'output/target/.root' doesn't exists anymore, as there's no Make rule to statisfy. The infrastructure are modified to filter host-skeleton. It's needed becauses the host-dependencies are derived from the dependencies of the target package where 'host-' is preprended to the depedency name. In the pkg-generic we add skeleton as a dependency to every package. The whole system/system.mk is now removed at the profit of package/skeleton/skeleton.mk [Thomas: - rebase on top of master and fix some minor conflicts - remove the 'select BR2_PACKAGE_SKELETON' in BR2_ROOTFS_SKELETON_DEFAULT and BR2_ROOTFS_SKELETON_CUSTOM, since anyway the skeleton package is always enabled. - fixup a few mistakes in the getty handling due to misnamed variables.] Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-rebar.mk')
-rw-r--r--package/pkg-rebar.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/pkg-rebar.mk b/package/pkg-rebar.mk
index 75facd55a3..c727489bef 100644
--- a/package/pkg-rebar.mk
+++ b/package/pkg-rebar.mk
@@ -192,11 +192,11 @@ ifeq ($$($(2)_USE_AUTOCONF),YES)
# is NO. Also filter the result of _AUTORECONF and _GETTEXTIZE away
# from the non-host rule
$(2)_DEPENDENCIES ?= $$(filter-out host-automake host-autoconf host-libtool \
- host-gettext host-toolchain host-erlang-rebar $(1),\
+ host-gettext host-skeleton host-toolchain host-erlang-rebar $(1),\
$$(patsubst host-host-%,host-%,$$(addprefix host-,$$($(3)_DEPENDENCIES))))
else
# Same deal, if _USE_BUNDLED_REBAR is NO.
-$(2)_DEPENDENCIES ?= $$(filter-out host-toolchain host-erlang-rebar $(1),\
+$(2)_DEPENDENCIES ?= $$(filter-out host-skeleton host-toolchain host-erlang-rebar $(1),\
$$(patsubst host-host-%,host-%,$$(addprefix host-,$$($(3)_DEPENDENCIES))))
endif
OpenPOWER on IntegriCloud