summaryrefslogtreecommitdiffstats
path: root/package/pkg-luarocks.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-02-05 10:44:00 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-05 12:09:35 +0100
commit3880a6ab3ca3890e79a7a429a58903217f36770d (patch)
treef275f787ddac92a4e3817b99a58816b43016cde6 /package/pkg-luarocks.mk
parente7ab4b49f4dd16a1312db3144376f26d4340e15e (diff)
downloadbuildroot-3880a6ab3ca3890e79a7a429a58903217f36770d.tar.gz
buildroot-3880a6ab3ca3890e79a7a429a58903217f36770d.zip
infra: remove redundant $(call) on pkgdir, pkgname, pkgparentdir
When calling make 'functions', the $(call) keyword is only needed if the function takes arguments. For pkgdir, pkgname and pkgparentdir this is not the case, so we can remove the call to make things more readable. Suggested-by: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-luarocks.mk')
-rw-r--r--package/pkg-luarocks.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-luarocks.mk b/package/pkg-luarocks.mk
index e82818a0c4..fdd26c750c 100644
--- a/package/pkg-luarocks.mk
+++ b/package/pkg-luarocks.mk
@@ -78,5 +78,5 @@ endef
# luarocks-package -- the target generator macro for LuaRocks packages
################################################################################
-luarocks-package = $(call inner-luarocks-package,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
+luarocks-package = $(call inner-luarocks-package,$(pkgname),$(call UPPERCASE,$(pkgname)),$(call UPPERCASE,$(pkgname)),$(pkgparentdir),target)
# host-luarocks-package not supported
OpenPOWER on IntegriCloud