summaryrefslogtreecommitdiffstats
path: root/package/pkg-luarocks.mk
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2017-02-23 18:00:25 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-03-02 22:39:30 +0100
commit0be874d89ab5c238279a1f2e867ce67497099b30 (patch)
treef98fdfad54ec8b5ca6b8fc581cc8954d91129de8 /package/pkg-luarocks.mk
parent2c8438866394f2146ab60c483a820e3ca78ce560 (diff)
downloadbuildroot-0be874d89ab5c238279a1f2e867ce67497099b30.tar.gz
buildroot-0be874d89ab5c238279a1f2e867ce67497099b30.zip
luarocks-package: use $(HOST_PKG_VERSION) instead of $(PKG_VERSION)
The inner-luarocks-package macro was using $(3)_VERSION as the package version, i.e. the version of the target package, even when it's the host package. We should instead use $(2)_VERSION, i.e. the host package version, like is done in inner-generic-package. Since luarocks-package doesn't even support a host version, it doens't make a whole lot of difference, but let's keep things consistent. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-luarocks.mk')
-rw-r--r--package/pkg-luarocks.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/pkg-luarocks.mk b/package/pkg-luarocks.mk
index da5c912c81..aa83e74a0e 100644
--- a/package/pkg-luarocks.mk
+++ b/package/pkg-luarocks.mk
@@ -34,9 +34,9 @@
define inner-luarocks-package
$(2)_BUILD_OPTS ?=
-$(2)_SUBDIR ?= $(1)-$$(shell echo "$$($(3)_VERSION)" | sed -e "s/-[0-9]$$$$//")
-$(2)_ROCKSPEC ?= $(1)-$$($(3)_VERSION).rockspec
-$(2)_SOURCE ?= $(1)-$$($(3)_VERSION).src.rock
+$(2)_SUBDIR ?= $(1)-$$(shell echo "$$($(2)_VERSION)" | sed -e "s/-[0-9]$$$$//")
+$(2)_ROCKSPEC ?= $(1)-$$($(2)_VERSION).rockspec
+$(2)_SOURCE ?= $(1)-$$($(2)_VERSION).src.rock
$(2)_SITE ?= $$(call qstrip,$$(BR2_LUAROCKS_MIRROR))
# Since we do not support host-luarocks-package, we know this is
OpenPOWER on IntegriCloud