summaryrefslogtreecommitdiffstats
path: root/package/pkg-kconfig.mk
diff options
context:
space:
mode:
authorYann E. Morin <yann.morin.1998@free.fr>2015-02-03 15:21:45 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-14 16:37:11 +0100
commitd1f94bf403416ef3d3a9cc40dfbd8063db8f3348 (patch)
tree9b610aa6c5ee68dd78600557883d787d1e43ea92 /package/pkg-kconfig.mk
parentd9fec0ad76133b2846f798496307909016ff2bd6 (diff)
downloadbuildroot-d1f94bf403416ef3d3a9cc40dfbd8063db8f3348.tar.gz
buildroot-d1f94bf403416ef3d3a9cc40dfbd8063db8f3348.zip
kconfig infra: only provide foo-*config targets when the package is enabled
Signed-off-by: "Yann E. Morin" <yann.morin.1998@free.fr> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-kconfig.mk')
-rw-r--r--package/pkg-kconfig.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/pkg-kconfig.mk b/package/pkg-kconfig.mk
index 8e6831521a..04ac37df42 100644
--- a/package/pkg-kconfig.mk
+++ b/package/pkg-kconfig.mk
@@ -66,6 +66,12 @@ $$($(2)_DIR)/.stamp_kconfig_fixup_done: $$($(2)_DIR)/.config
# Before running configure, the configuration file should be present and fixed
$$($(2)_TARGET_CONFIGURE): $$($(2)_DIR)/.stamp_kconfig_fixup_done
+# Only enable the foo-*config targets when the package is actually enabled.
+# Note: the variable $(2)_KCONFIG_VAR is not related to the kconfig
+# infrastructure, but defined by pkg-generic.mk. The generic infrastructure is
+# already called above, so we can effectively use this variable.
+ifeq ($$($$($(2)_KCONFIG_VAR)),y)
+
# Configuration editors (menuconfig, ...)
$$(addprefix $(1)-,$$($(2)_KCONFIG_EDITORS)): $$($(2)_DIR)/.stamp_kconfig_fixup_done
$$($(2)_MAKE_ENV) $$(MAKE) -C $$($(2)_DIR) \
@@ -92,6 +98,8 @@ $(1)-update-defconfig: $(1)-savedefconfig
cp -f $$($(2)_DIR)/defconfig $$($(2)_KCONFIG_FILE)
touch --reference $$($(2)_DIR)/.config $$($(2)_KCONFIG_FILE)
+endif # package enabled
+
endef # inner-kconfig-package
################################################################################
OpenPOWER on IntegriCloud