summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-07-01 11:01:19 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-07-02 19:11:14 +0200
commitec3e057f79117d851c37f19316a3b9b5e2470550 (patch)
tree374d1fdd9d4b6e05a12e43e81ee5de087486f076 /package/pkg-generic.mk
parentf109e7eeb53ecfa084f80899646b68fb6dff021d (diff)
downloadbuildroot-ec3e057f79117d851c37f19316a3b9b5e2470550.tar.gz
buildroot-ec3e057f79117d851c37f19316a3b9b5e2470550.zip
core/pkg-infra: download git submodules if the package wants them
Add a new package variable that packages can set to specify that they need git submodules. Only accept this option if the download method is git, as we can not get submodules via an http download (via wget). Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Aleksandar Simeonov <aleksandar@barix.com> Tested-by: Matt Weber <matt@thewebers.ws> Reviewed-by: Matt Weber <matt@thewebers.ws> Tested-By: Nicolas Cavallari <nicolas.cavallari@green-communications.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index b712c3175f..fa404cae24 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -468,6 +468,14 @@ ifndef $(2)_SITE_METHOD
endif
endif
+# Do not accept to download git submodule if not using the git method
+ifneq ($$($(2)_GIT_SUBMODULES),)
+ ifneq ($$($(2)_SITE_METHOD),git)
+ $$(error $(2) declares having git sub-modules, but does not use the \
+ 'git' method (uses '$$($(2)_SITE_METHOD)' instead))
+ endif
+endif
+
ifeq ($$($(2)_SITE_METHOD),local)
ifeq ($$($(2)_OVERRIDE_SRCDIR),)
$(2)_OVERRIDE_SRCDIR = $$($(2)_SITE)
OpenPOWER on IntegriCloud