summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-29 19:33:16 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-30 23:38:40 +0200
commit524a555ad1f81f132aaed0badaece1b8b95c8ae7 (patch)
tree74bec4dfa3414e760c43321e7922e6b33622a02d /package/pkg-generic.mk
parent7430a41801b2c1785723600ec84e0607e01923b3 (diff)
downloadbuildroot-524a555ad1f81f132aaed0badaece1b8b95c8ae7.tar.gz
buildroot-524a555ad1f81f132aaed0badaece1b8b95c8ae7.zip
pkg-generic: fix the logic showing the "Downloading" message
Even though the .stamp_downloaded target is executed for each package being built, the pkg-generic infrastructure tries to not display the "Downloading" message when there is in fact nothing to download. Unfortunately, the logic was incorrect for the patch download: it forgot the fact that <pkg>_PATCH can contain either file names (in which case we assume the patch should be downloaded from <pkg>_SITE), or full URLs. The latter case was not properly handled, as we were checking if $(DL_DIR)/<full URL> existed, while we should be testing if $(DL_DIR)/`basename <full URL>` exists. This patch fixes that, which makes sure the "Downloading" message is displayed only when necessary. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index c1b379bf87..b44d476379 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -77,7 +77,7 @@ ifeq ($(DL_MODE),DOWNLOAD)
$(call MESSAGE,"Downloading") ; \
else \
for p in $($(PKG)_PATCH) ; do \
- if test ! -e $(DL_DIR)/$$p ; then \
+ if test ! -e $(DL_DIR)/`basename $$p` ; then \
$(call MESSAGE,"Downloading") ; \
break ; \
fi ; \
OpenPOWER on IntegriCloud