summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-05-07 18:14:33 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-24 16:18:16 +0200
commit1273636fc686cd788b6de87be75dd0726cf8676c (patch)
treef7642edb3d5ed4a785d5f527eb6d5e512b7a4a5c /package/pkg-generic.mk
parent19241598147e7555dce40b6dd44b28ef22b67ed9 (diff)
downloadbuildroot-1273636fc686cd788b6de87be75dd0726cf8676c.tar.gz
buildroot-1273636fc686cd788b6de87be75dd0726cf8676c.zip
core/legal-info: also save patches
Currently, the legal-info infra only saves the source archive of a package. However, that's not enough as we may apply some patches on packages sources. We do suggest users to also redistribute the Buildroot sources as part of their compliance distribution, so the patches bundled in Buildroot would indeed be included in the compliance distribution. However, that's still not enough, since we may download some patches, or the user may use a global patch directory. Patches in there might not end up in the compliance distribution, and there are risks of non-conformity. So, always include patches alongside the source archive. To ensure reproducibility, we also generate a series file, so patches can be re-applied in the correct order. We get the list of patches to include from the list of patches that were applied by the package infrastructure (via the apply-patches support script). So, we need to get packages properly extracted and patched before we can save their legal-info, not just in the case they define _LICENSE_FILES. Update the legal-info header accordingly. Note: this means that, when a package is not patched and defines no LICENSE_FILES, we will extract and patch it for nothing. There is no easy way to know whether we have to patch a package or not. We can only either duplicate the logic to detect patches (bad) or rely on the infra actually patching the package. Also, a vast majority of packages are either patched, or define _LICENSE_FILES, so it is best and easiest to always extract and patch them prior to legal-info. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Luca Ceresoli <luca@lucaceresoli.net> Tested-by: Luca Ceresoli <luca@lucaceresoli.net> Reviewed-by: Luca Ceresoli <luca@lucaceresoli.net> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk15
1 files changed, 10 insertions, 5 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index fa68f14ca0..2508d75cce 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -749,12 +749,10 @@ $(2)_MANIFEST_LICENSE_FILES = $$($(2)_LICENSE_FILES)
endif
$(2)_MANIFEST_LICENSE_FILES ?= not saved
-# If the package declares _LICENSE_FILES, we need to extract it,
-# for overriden, local or normal remote packages alike, whether
-# we want to redistribute it or not.
-ifneq ($$($(2)_LICENSE_FILES),)
+# We need to extract and patch a package to be able to retrieve its
+# license files (if any) and the list of patches applied to it (if
+# any).
$(1)-legal-info: $(1)-patch
-endif
# We only save the sources of packages we want to redistribute, that are
# non-overriden (local or true override).
@@ -810,6 +808,13 @@ endif
$$(Q)support/scripts/hardlink-or-copy \
$$(DL_DIR)/$$($(2)_ACTUAL_SOURCE_TARBALL) \
$$($(2)_REDIST_SOURCES_DIR)
+# Save patches and generate the series file
+ $$(Q)while read f; do \
+ support/scripts/hardlink-or-copy \
+ $$$${f} \
+ $$($(2)_REDIST_SOURCES_DIR) || exit 1; \
+ printf "%s\n" "$$$${f##*/}" >>$$($(2)_REDIST_SOURCES_DIR)/series || exit 1; \
+ done <$$($(2)_DIR)/.applied_patches_list
endif # redistribute
endif # other packages
OpenPOWER on IntegriCloud