summaryrefslogtreecommitdiffstats
path: root/package/php-ssh2
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-01-28 18:26:30 -0300
committerPeter Korsgaard <peter@korsgaard.com>2014-02-12 15:57:38 +0100
commit555120da7cc9b5500886dfb8266368cce538c5b7 (patch)
tree75df43cf9d80d85b8102351b112ad2aae12ede1b /package/php-ssh2
parent534039b3297042acb632652469019347b9966700 (diff)
downloadbuildroot-555120da7cc9b5500886dfb8266368cce538c5b7.tar.gz
buildroot-555120da7cc9b5500886dfb8266368cce538c5b7.zip
php-ssh2: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/php-ssh2')
-rw-r--r--package/php-ssh2/Config.in8
-rw-r--r--package/php-ssh2/php-ssh2.mk26
2 files changed, 34 insertions, 0 deletions
diff --git a/package/php-ssh2/Config.in b/package/php-ssh2/Config.in
new file mode 100644
index 0000000000..b457900740
--- /dev/null
+++ b/package/php-ssh2/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PHP_SSH2
+ bool "php-ssh2"
+ depends on BR2_PACKAGE_PHP
+ select BR2_PACKAGE_LIBSSH2
+ help
+ PHP bindings for the libssh2 library.
+
+ http://pecl.php.net/package/ssh2
diff --git a/package/php-ssh2/php-ssh2.mk b/package/php-ssh2/php-ssh2.mk
new file mode 100644
index 0000000000..f2067a4dfa
--- /dev/null
+++ b/package/php-ssh2/php-ssh2.mk
@@ -0,0 +1,26 @@
+################################################################################
+#
+# php-ssh2
+#
+################################################################################
+
+PHP_SSH2_VERSION = 0.12
+PHP_SSH2_SOURCE = ssh2-$(PHP_SSH2_VERSION).tgz
+PHP_SSH2_SITE = http://pecl.php.net/get
+PHP_SSH2_CONF_OPT = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
+ --with-ssh2=$(STAGING_DIR)/usr
+# phpize does the autoconf magic
+PHP_SSH2_DEPENDENCIES = libssh2 php host-autoconf
+PHP_SSH2_LICENSE = PHP
+PHP_SSH2_LICENSE_FILES = LICENSE
+
+define PHP_SSH2_PHPIZE
+ (cd $(@D); \
+ PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
+ PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
+ $(STAGING_DIR)/usr/bin/phpize)
+endef
+
+PHP_SSH2_PRE_CONFIGURE_HOOKS += PHP_SSH2_PHPIZE
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud