summaryrefslogtreecommitdiffstats
path: root/package/pciutils
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-09-18 10:38:03 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2013-09-18 16:57:23 +0200
commit95cc2aab61f9c8ea21d4b1cc45f4aa13310e9637 (patch)
tree2514c59e42dd25977f7489eac6b833794f3962de /package/pciutils
parent22718b0e2c1d2b471ef60dc7992ad94376bb48b7 (diff)
downloadbuildroot-95cc2aab61f9c8ea21d4b1cc45f4aa13310e9637.tar.gz
buildroot-95cc2aab61f9c8ea21d4b1cc45f4aa13310e9637.zip
pciutils: fixup library permissions
libpci.so* is installed without +x permissions thus preventing stripping. Fix it up in the post install target hooks. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pciutils')
-rw-r--r--package/pciutils/pciutils.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index 350ca0d352..fd6f8aa57d 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -65,4 +65,12 @@ define PCIUTILS_INSTALL_STAGING_CMDS
SHARED=$(PCIUTILS_SHARED) install install-lib
endef
+
+# Library lacks +x so strip skips it
+define PCIUTILS_FIX_LIBRARY_MODE
+ -chmod +x $(TARGET_DIR)/usr/lib/libpci.so*
+endef
+
+PCIUTILS_POST_INSTALL_TARGET_HOOKS += PCIUTILS_FIX_LIBRARY_MODE
+
$(eval $(generic-package))
OpenPOWER on IntegriCloud