summaryrefslogtreecommitdiffstats
path: root/package/orbit
diff options
context:
space:
mode:
authorAssaf Inbal <shmuelzon@gmail.com>2013-05-20 15:56:44 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-08-13 11:05:08 +0200
commit02e4326fe7f1912a6f12bdef54c7295f9188dd38 (patch)
tree1d48cbb175b09c83275de5efce20e419e0c68f86 /package/orbit
parentf608c7705fba9a7f83aef28afe5a841fafe527e9 (diff)
downloadbuildroot-02e4326fe7f1912a6f12bdef54c7295f9188dd38.tar.gz
buildroot-02e4326fe7f1912a6f12bdef54c7295f9188dd38.zip
orbit: New package
An MVC web framework for Lua [Thomas P: add patch to fix installation procedure, and use the provided Makefile for installation. Remove build-time dependency on wsapi since there's nothing to build in 'orbit'. Remove run-time dependency on 'rings', since it's not clear why Orbit would depend on that.] Signed-off-by: Assaf Inbal <shmuelzon@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/orbit')
-rw-r--r--package/orbit/Config.in10
-rw-r--r--package/orbit/orbit-01-fix-installation.patch26
-rw-r--r--package/orbit/orbit.mk19
3 files changed, 55 insertions, 0 deletions
diff --git a/package/orbit/Config.in b/package/orbit/Config.in
new file mode 100644
index 0000000000..556c46eaa3
--- /dev/null
+++ b/package/orbit/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_ORBIT
+ bool "orbit"
+ # These are runtime dependencies
+ select BR2_PACKAGE_WSAPI
+ select BR2_PACKAGE_LUAFILESYSTEM
+ help
+ An MVC web framework for Lua. The design is inspired by lightweight
+ Ruby frameworks such as Camping
+
+ http://keplerproject.github.com/orbit
diff --git a/package/orbit/orbit-01-fix-installation.patch b/package/orbit/orbit-01-fix-installation.patch
new file mode 100644
index 0000000000..ae50ad9fe5
--- /dev/null
+++ b/package/orbit/orbit-01-fix-installation.patch
@@ -0,0 +1,26 @@
+Fix installation commands
+
+The installation commands did not match the location of the source
+files within the Orbit source tree.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -11,12 +11,9 @@
+ mkdir -p $(LUA_DIR)
+ cp src/orbit.lua $(LUA_DIR)
+ mkdir -p $(LUA_DIR)/orbit
+- cp src/model.lua $(LUA_DIR)/orbit
+- cp src/cache.lua $(LUA_DIR)/orbit
+- cp src/pages.lua $(LUA_DIR)/orbit
+- cp src/ophandler.lua $(LUA_DIR)/orbit
++ cp src/orbit/*.lua $(LUA_DIR)/orbit
+ mkdir -p $(BIN_DIR)
+- cp src/orbit $(BIN_DIR)
++ cp src/launchers/* $(BIN_DIR)
+ if [ -f ./wsapi/Makefile ]; then \
+ cd wsapi && make install; \
+ fi
diff --git a/package/orbit/orbit.mk b/package/orbit/orbit.mk
new file mode 100644
index 0000000000..af5f0af94d
--- /dev/null
+++ b/package/orbit/orbit.mk
@@ -0,0 +1,19 @@
+################################################################################
+#
+# orbit
+#
+################################################################################
+
+ORBIT_VERSION = 2.2.0
+ORBIT_SITE = http://github.com/downloads/keplerproject/orbit
+ORBIT_LICENSE = MIT
+ORBIT_LICENSE_FILES = COPYRIGHT
+
+define ORBIT_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(@D) \
+ LUA_DIR=$(TARGET_DIR)/usr/share/lua/ \
+ BIN_DIR=$(TARGET_DIR)/usr/bin \
+ install
+endef
+
+$(eval $(generic-package))
OpenPOWER on IntegriCloud