summaryrefslogtreecommitdiffstats
path: root/package/opencv
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2017-05-27 13:52:37 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-05-27 17:16:06 +0200
commitcbf2b6e3db65500f7bb29aa029a620570026373c (patch)
tree77a13c821ae239c02d8247fde874d74aab322177 /package/opencv
parente1404d5b4eaed845223b409a6673230c64128115 (diff)
downloadbuildroot-cbf2b6e3db65500f7bb29aa029a620570026373c.tar.gz
buildroot-cbf2b6e3db65500f7bb29aa029a620570026373c.zip
package/opencv: fix build with old glibc versions
Prior to glibc 2.18, definitions like SIZE_MAX or INT_FAST32_MAX from <stdint.h> were only made available for C code, or in C++ if __STDC_LIMIT_MACROS was defined. The code from jasper uses such definitions, without defining __STDC_LIMIT_MACROS. Unfortunately, defining __STDC_LIMIT_MACROS in the jasper headers doesn't work, since <stdint.h> has already been included before, at a point where __STDC_LIMIT_MACROS was not defined. So to solve this problem, we simply pass -D__STDC_LIMIT_MACROS in CXXFLAGS when building opencv with jasper support. This patch uses the same solution used for libraw: https://git.buildroot.net/buildroot/commit/package/libraw?id=d246cf5fd01bb0d20a0e64194ffed514ea8dd0aa Fixes: http://autobuild.buildroot.net/results/095/095f7574afdb633c59a625cd063de03644b6d3a7/ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/opencv')
-rw-r--r--package/opencv/opencv.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/opencv/opencv.mk b/package/opencv/opencv.mk
index ff5ab02b16..92cfd431a0 100644
--- a/package/opencv/opencv.mk
+++ b/package/opencv/opencv.mk
@@ -192,7 +192,8 @@ OPENCV_CONF_OPTS += -DWITH_GTK=OFF
endif
ifeq ($(BR2_PACKAGE_OPENCV_WITH_JASPER),y)
-OPENCV_CONF_OPTS += -DWITH_JASPER=ON
+OPENCV_CONF_OPTS += -DWITH_JASPER=ON \
+ -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) -D__STDC_LIMIT_MACROS"
OPENCV_DEPENDENCIES += jasper
else
OPENCV_CONF_OPTS += -DWITH_JASPER=OFF
OpenPOWER on IntegriCloud