summaryrefslogtreecommitdiffstats
path: root/package/nodejs
diff options
context:
space:
mode:
authorMartin Bark <martin@barkynet.com>2016-01-30 14:51:00 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-07 23:35:25 +0100
commit75b7049281d11867ed6611a2a1a6a15dadb0b031 (patch)
treef6479a4c5b6f3f52f3b809cfdd0399b0e584adf8 /package/nodejs
parent976380ce27f682f735ae3d3dc78e3a8d58e81a28 (diff)
downloadbuildroot-75b7049281d11867ed6611a2a1a6a15dadb0b031.tar.gz
buildroot-75b7049281d11867ed6611a2a1a6a15dadb0b031.zip
package/nodejs: remove version choice
Remove the choice of nodejs version. Now automatically pick nodejs 0.10.x for armv5 architectures only and the latest nodejs for all other supported architectures. Note that the removal of BR2_PACKAGE_NODEJS_5_X is not handled in Config.in.legacy because buildroot has never been released with this option included. Signed-off-by: Martin Bark <martin@barkynet.com> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/nodejs')
-rw-r--r--package/nodejs/Config.in38
-rw-r--r--package/nodejs/nodejs.mk2
2 files changed, 11 insertions, 29 deletions
diff --git a/package/nodejs/Config.in b/package/nodejs/Config.in
index 4385646ac8..cdf770552d 100644
--- a/package/nodejs/Config.in
+++ b/package/nodejs/Config.in
@@ -1,9 +1,10 @@
-comment "nodejs needs a toolchain w/ C++, dynamic library, threads"
+comment "nodejs needs a toolchain w/ C++, dynamic library, threads, gcc >= 4.8, wchar"
depends on BR2_USE_MMU
depends on BR2_arm || BR2_i386 || BR2_x86_64 || BR2_mipsel
depends on !BR2_MIPS_SOFT_FLOAT
depends on !BR2_ARM_CPU_ARMV4
- depends on !BR2_INSTALL_LIBSTDCPP || BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
+ depends on !BR2_INSTALL_LIBSTDCPP || BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS || \
+ !BR2_HOST_GCC_AT_LEAST_4_8 || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 || !BR2_USE_WCHAR
config BR2_PACKAGE_NODEJS
bool "nodejs"
@@ -13,6 +14,11 @@ config BR2_PACKAGE_NODEJS
depends on !BR2_MIPS_SOFT_FLOAT
# ARM needs BLX, so v5t+
depends on !BR2_ARM_CPU_ARMV4
+ # 0.10.x could be built without the following toolchain dependencies but
+ # simplify things by requiring these basic dependencies for all versions.
+ depends on BR2_HOST_GCC_AT_LEAST_4_8
+ depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
+ depends on BR2_USE_WCHAR
# uses fork()
depends on BR2_USE_MMU
# uses dlopen(). On ARMv5, we could technically support static
@@ -35,34 +41,10 @@ config BR2_PACKAGE_NODEJS_V8_ARCH_SUPPORTS
# On ARM, at least ARMv6+ with VFPv2+ is needed
default y if !BR2_ARM_CPU_ARMV5 && BR2_ARM_CPU_HAS_VFPV2
-choice
- prompt "Node.js version"
- default BR2_PACKAGE_NODEJS_0_10_X if BR2_ARM_CPU_ARMV5
- default BR2_PACKAGE_NODEJS_5_X
- help
- Select the version of Node.js you wish to use.
-
-config BR2_PACKAGE_NODEJS_0_10_X
- bool "v0.10.41"
-
-config BR2_PACKAGE_NODEJS_5_X
- bool "v5.5.0"
- depends on BR2_PACKAGE_NODEJS_V8_ARCH_SUPPORTS
- depends on BR2_HOST_GCC_AT_LEAST_4_8
- depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
- depends on BR2_USE_WCHAR
-
-comment "v5.5.0 needs a toolchain w/ gcc >= 4.8, wchar"
- depends on BR2_PACKAGE_NODEJS_V8_ARCH_SUPPORTS
- depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 || !BR2_USE_WCHAR
- depends on BR2_HOST_GCC_AT_LEAST_4_8
-
-endchoice
-
config BR2_PACKAGE_NODEJS_VERSION_STRING
string
- default "0.10.41" if BR2_PACKAGE_NODEJS_0_10_X
- default "5.5.0" if BR2_PACKAGE_NODEJS_5_X
+ default "5.5.0" if BR2_PACKAGE_NODEJS_V8_ARCH_SUPPORTS
+ default "0.10.41"
menu "Module Selection"
diff --git a/package/nodejs/nodejs.mk b/package/nodejs/nodejs.mk
index af47b269c8..37de331f12 100644
--- a/package/nodejs/nodejs.mk
+++ b/package/nodejs/nodejs.mk
@@ -5,7 +5,7 @@
################################################################################
NODEJS_VERSION = $(call qstrip,$(BR2_PACKAGE_NODEJS_VERSION_STRING))
-ifeq ($(BR2_PACKAGE_NODEJS_5_X),y)
+ifeq ($(findstring 0.10.,$(NODEJS_VERSION)),)
NODEJS_SOURCE = node-v$(NODEJS_VERSION).tar.xz
else
NODEJS_SOURCE = node-v$(NODEJS_VERSION).tar.gz
OpenPOWER on IntegriCloud