summaryrefslogtreecommitdiffstats
path: root/package/ncurses
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-09-17 10:08:17 -0300
committerPeter Korsgaard <peter@korsgaard.com>2014-09-17 23:00:58 +0200
commit542e7adf59d1d61cfc8b058895d8a8816fef7cfe (patch)
treefe485f3b78d73ef64aa12ad7ae3a318a89041e38 /package/ncurses
parent74efae025371fbb0540f3184c66a1fd0a3c34abd (diff)
downloadbuildroot-542e7adf59d1d61cfc8b058895d8a8816fef7cfe.tar.gz
buildroot-542e7adf59d1d61cfc8b058895d8a8816fef7cfe.zip
package/ncurses: fixup library symlinks
As stated on the list we need to copy static libraries when doing static targets so add the logic for that. Also exclude the wide option for blackfin flat since there seem to be toolchain issues with that combination - since it's a new feature option someone interested might look into it later. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/ncurses')
-rw-r--r--package/ncurses/Config.in2
-rw-r--r--package/ncurses/ncurses.mk15
2 files changed, 15 insertions, 2 deletions
diff --git a/package/ncurses/Config.in b/package/ncurses/Config.in
index b90ec9e597..3cc0a374ba 100644
--- a/package/ncurses/Config.in
+++ b/package/ncurses/Config.in
@@ -13,6 +13,8 @@ if BR2_PACKAGE_NCURSES
config BR2_PACKAGE_NCURSES_WCHAR
bool "enable wide char support"
depends on BR2_USE_WCHAR
+ # Build broken @ curses.priv.h with bad declarations
+ depends on !(BR2_bfin && BR2_BINFMT_FLAT)
help
Enable wide char & UTF-8 support in ncurses libraries
diff --git a/package/ncurses/ncurses.mk b/package/ncurses/ncurses.mk
index bd2aac017f..81a39988ad 100644
--- a/package/ncurses/ncurses.mk
+++ b/package/ncurses/ncurses.mk
@@ -40,15 +40,26 @@ ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
NCURSES_CONF_OPT += --enable-widec
NCURSES_LIB_SUFFIX = w
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
define NCURSES_LINK_LIBS
for lib in $(NCURSES_LIBS-y); do \
+ ln -sf $${lib}$(NCURSES_LIB_SUFFIX).a \
+ $(1)/usr/lib/$${lib}.a; \
+ done
+endef
+else
+define NCURSES_LINK_LIBS
+ for lib in $(NCURSES_LIBS-y); do \
+ ln -sf $${lib}$(NCURSES_LIB_SUFFIX).a \
+ $(1)/usr/lib/$${lib}.a; \
ln -sf $${lib}$(NCURSES_LIB_SUFFIX).so \
$(1)/usr/lib/$${lib}.so; \
done
endef
+endif
-NCURSES_LINK_TARGET_LIBS = $(call NCURSES_LINK_LIBS, $(TARGET_DIR))
-NCURSES_LINK_STAGING_LIBS = $(call NCURSES_LINK_LIBS, $(STAGING_DIR))
+NCURSES_LINK_TARGET_LIBS = $(call NCURSES_LINK_LIBS, $(TARGET_DIR))
+NCURSES_LINK_STAGING_LIBS = $(call NCURSES_LINK_LIBS, $(STAGING_DIR))
NCURSES_POST_INSTALL_STAGING_HOOKS += NCURSES_LINK_STAGING_LIBS
OpenPOWER on IntegriCloud