summaryrefslogtreecommitdiffstats
path: root/package/mutt/mutt.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-11-29 11:55:56 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-08 00:05:05 +0100
commit18ebf0e5e1e495cad670c085e5932c09cd84ae3b (patch)
tree82db3759c4f99f8bbc58a0409a4d9d4e80787743 /package/mutt/mutt.mk
parentc3848823e8dd1c9f17935533e91c8e0fbb2f0bf1 (diff)
downloadbuildroot-18ebf0e5e1e495cad670c085e5932c09cd84ae3b.tar.gz
buildroot-18ebf0e5e1e495cad670c085e5932c09cd84ae3b.zip
package/mutt: specify the mailpath
mutt's ./configure looks for different paths for where to look for incoming mails. This is absolutely worng in the case of cross-compilation, because the path it may find on the host may not exist on the target. Not only that, but some host may not even have any of the paths ./configure looks for. Fix that by specifying the mailpath, and set it to the value documented in the FHS [0] Since Buildroot only guarantees /tmp to be writable, make /var/mail a symlink to /tmp . [0] http://refspecs.linuxfoundation.org/FHS_2.3/fhs-2.3.html#VARMAILUSERMAILBOXFILES Reported-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/mutt/mutt.mk')
-rw-r--r--package/mutt/mutt.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/mutt/mutt.mk b/package/mutt/mutt.mk
index b4f18b0f7a..92457a1871 100644
--- a/package/mutt/mutt.mk
+++ b/package/mutt/mutt.mk
@@ -57,4 +57,11 @@ MUTT_CONF_ENV += \
mutt_cv_iconv_good=yes \
mutt_cv_iconv_nontrans=no
+MUTT_CONF_OPTS += --with-mailpath=/var/mail
+
+define MUTT_VAR_MAIL
+ ln -sf /tmp $(TARGET_DIR)/var/mail
+endef
+MUTT_POST_INSTALL_TARGET_HOOKS += MUTT_VAR_MAIL
+
$(eval $(autotools-package))
OpenPOWER on IntegriCloud