summaryrefslogtreecommitdiffstats
path: root/package/musl
diff options
context:
space:
mode:
authorCharles Duffy <charles@dyfis.net>2015-10-15 10:27:18 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-19 23:04:48 +0200
commit84120c10f5ba6c8c4b8d32068616cbdb8a8a8102 (patch)
treefd52c11a274c45e4c6635c1b85fbc8a7750b1590 /package/musl
parentb14269ea4f34c741c29f1c58e825b5ef2a399e0c (diff)
downloadbuildroot-84120c10f5ba6c8c4b8d32068616cbdb8a8a8102.tar.gz
buildroot-84120c10f5ba6c8c4b8d32068616cbdb8a8a8102.zip
musl: Make only shared libraries conditional
External toolchain use requires a static libc (as buildroot uses `gcc --print-file-name libc.a` to find the sysroot); thus, the static portion of a musl build should not be conditional. Signed-off-by: Charles Duffy <chaduffy@cisco.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/musl')
-rw-r--r--package/musl/musl.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/musl/musl.mk b/package/musl/musl.mk
index f0c45f538b..2f43aabb33 100644
--- a/package/musl/musl.mk
+++ b/package/musl/musl.mk
@@ -29,7 +29,8 @@ define MUSL_CONFIGURE_CMDS
--prefix=/usr \
--libdir=/lib \
--disable-gcc-wrapper \
- $(SHARED_STATIC_LIBS_OPTS))
+ --enable-static \
+ $(if $(BR2_STATIC_LIBS),--disable-shared,--enable-shared))
endef
define MUSL_BUILD_CMDS
OpenPOWER on IntegriCloud