summaryrefslogtreecommitdiffstats
path: root/package/mplayer
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2015-10-14 15:15:24 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-15 13:28:11 +0200
commit9731582d5c10d362878a194aa34bfcc0825a4395 (patch)
treefa43372e5798126045c7f2e832d8e36ffb89b5d8 /package/mplayer
parentf63dc20700da5bf5b7373a73c435f0019d26f097 (diff)
downloadbuildroot-9731582d5c10d362878a194aa34bfcc0825a4395.tar.gz
buildroot-9731582d5c10d362878a194aa34bfcc0825a4395.zip
mplayer: enable apng and tdsc only if zlib is available
apng and tdsc are enabled by default, but they need zlib, otherwise the compilation will fail with an error like this one: libavcodec/pngdec.c:35:18: fatal error: zlib.h: No such file or directory #include <zlib.h> ^ compilation terminated. So add an autodep on BR2_PACKAGE_ZLIB to enable or disable support for apng and tdsc accordingly. Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/mplayer')
-rw-r--r--package/mplayer/mplayer.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/mplayer/mplayer.mk b/package/mplayer/mplayer.mk
index d896b350c1..2f588643d5 100644
--- a/package/mplayer/mplayer.mk
+++ b/package/mplayer/mplayer.mk
@@ -27,6 +27,19 @@ else
MPLAYER_CONF_OPTS += --disable-big-endian
endif
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+MPLAYER_DEPENDENCIES += zlib
+MPLAYER_CONF_OPTS += \
+ --enable-decoder=apng \
+ --enable-encoder=apng \
+ --enable-decoder=tdsc
+else
+MPLAYER_CONF_OPTS += \
+ --disable-decoder=apng \
+ --disable-encoder=apng \
+ --disable-decoder=tdsc
+endif
+
ifeq ($(BR2_PACKAGE_SDL),y)
MPLAYER_CONF_OPTS += \
--enable-sdl \
OpenPOWER on IntegriCloud