summaryrefslogtreecommitdiffstats
path: root/package/lzo/lzo.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-09-02 16:28:53 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-09-02 18:41:01 +0200
commit802aaa55b9aece24db79b243e0fdf3f60ea6e69b (patch)
tree5a9eb2e065a745b6b6b2d951fabd757aea98d9da /package/lzo/lzo.mk
parentd02b7bfab1cbd58601ee7614ad54421f0ad15270 (diff)
downloadbuildroot-802aaa55b9aece24db79b243e0fdf3f60ea6e69b.tar.gz
buildroot-802aaa55b9aece24db79b243e0fdf3f60ea6e69b.zip
package/lzo: enable shared/static libs when needed
In 61c4c63 (package/lzo: switch to cmake), building lzo has switched from autotools to cmake. In the conversion, we've lost the build of the shared library, because the cmake-based buildsystem of lzo explcitly disables it by default. Restore the shared library build. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lzo/lzo.mk')
-rw-r--r--package/lzo/lzo.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/lzo/lzo.mk b/package/lzo/lzo.mk
index dba965fcd3..27ca459acf 100644
--- a/package/lzo/lzo.mk
+++ b/package/lzo/lzo.mk
@@ -11,5 +11,17 @@ LZO_LICENSE_FILES = COPYING
LZO_INSTALL_STAGING = YES
LZO_SUPPORTS_IN_SOURCE_BUILD = NO
+ifeq ($(BR2_SHARED_LIBS)$(BR2_SHARED_STATIC_LIBS),y)
+LZO_CONF_OPTS += -DENABLE_SHARED=ON
+else
+LZO_CONF_OPTS += -DENABLE_SHARED=OFF
+endif
+
+ifeq ($(BR2_STATIC_LIBS)$(BR2_SHARED_STATIC_LIBS),y)
+LZO_CONF_OPTS += -DENABLE_STATIC=ON
+else
+LZO_CONF_OPTS += -DENABLE_STATIC=OFF
+endif
+
$(eval $(cmake-package))
$(eval $(host-cmake-package))
OpenPOWER on IntegriCloud