summaryrefslogtreecommitdiffstats
path: root/package/lua
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-08-14 22:23:03 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-08-14 22:24:07 +0200
commit25a2650086ad9fe0e22e2a2c3d4e64cae396fcf1 (patch)
tree5c3e47724189de7f14f42959172e9bd74714b14d /package/lua
parent7ec15db9db138c71133413fbc9f354de9b74e309 (diff)
downloadbuildroot-25a2650086ad9fe0e22e2a2c3d4e64cae396fcf1.tar.gz
buildroot-25a2650086ad9fe0e22e2a2c3d4e64cae396fcf1.zip
lua: ensure pkgconfig directory exists before installing files
The lua staging and host installation commands generate a file in usr/lib/pkgconfig, without first making sure that this directory exists, which causes build failures if it doesn't. This commit adjusts those installation commands to create this directory if needed. Fixes: http://autobuild.buildroot.net/results/101c89e1d6aee942a0b1c4e4f3daf8ac2414a56c/ Based on investigation and initial (more complicated) fix provided by Francois Perrad <francois.perrad@gadz.org>. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lua')
-rw-r--r--package/lua/lua.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/lua/lua.mk b/package/lua/lua.mk
index 0692c53764..ee39480dc5 100644
--- a/package/lua/lua.mk
+++ b/package/lua/lua.mk
@@ -86,6 +86,7 @@ endef
define LUA_INSTALL_STAGING_CMDS
$(TARGET_MAKE_ENV) $(MAKE) INSTALL_TOP="$(STAGING_DIR)/usr" -C $(@D) install
+ mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig/
sed -e "s/@MYLIBS@/$(LUA_MYLIBS)/g" $(@D)/etc/lua.pc \
> $(STAGING_DIR)/usr/lib/pkgconfig/lua.pc
endef
@@ -96,6 +97,7 @@ endef
define HOST_LUA_INSTALL_CMDS
$(HOST_MAKE_ENV) $(MAKE) INSTALL_TOP="$(HOST_DIR)" -C $(@D) install
+ mkdir -p $(HOST_DIR)/lib/pkgconfig/
sed -e "s/@MYLIBS@/$(HOST_LUA_MYLIBS)/g" $(@D)/etc/lua.pc \
> $(HOST_DIR)/lib/pkgconfig/lua.pc
endef
OpenPOWER on IntegriCloud