summaryrefslogtreecommitdiffstats
path: root/package/lua-cqueues
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2017-09-24 18:18:56 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-10-03 22:04:44 +0200
commitc96e7eb504a273cb28525d2431b723dc1303aec6 (patch)
tree79d7504cb9adaf3b13f1242be28c8d109859764f /package/lua-cqueues
parentfbb48301ad2cd3ad19005f618907af211beeb348 (diff)
downloadbuildroot-c96e7eb504a273cb28525d2431b723dc1303aec6.tar.gz
buildroot-c96e7eb504a273cb28525d2431b723dc1303aec6.zip
lua-cqueues: new package
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lua-cqueues')
-rw-r--r--package/lua-cqueues/Config.in12
-rw-r--r--package/lua-cqueues/lua-cqueues.hash2
-rw-r--r--package/lua-cqueues/lua-cqueues.mk23
3 files changed, 37 insertions, 0 deletions
diff --git a/package/lua-cqueues/Config.in b/package/lua-cqueues/Config.in
new file mode 100644
index 0000000000..60f022848b
--- /dev/null
+++ b/package/lua-cqueues/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_LUA_CQUEUES
+ bool "lua-cqueues"
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ select BR2_PACKAGE_OPENSSL
+ help
+ Continuation Queues: Embeddable asynchronous networking,
+ threading, and notification framework for Lua on Unix.
+
+ http://25thandclement.com/~william/projects/cqueues.html
+
+comment "lua-cqueues needs a toolchain w/ threads"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/lua-cqueues/lua-cqueues.hash b/package/lua-cqueues/lua-cqueues.hash
new file mode 100644
index 0000000000..9fd664d69a
--- /dev/null
+++ b/package/lua-cqueues/lua-cqueues.hash
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 ae51b713bdf966215b87244e03ac60b5a12beb82d15dfb02755a000cfb2df905 lua-cqueues-rel-20161215.tar.gz
diff --git a/package/lua-cqueues/lua-cqueues.mk b/package/lua-cqueues/lua-cqueues.mk
new file mode 100644
index 0000000000..4f4be1e049
--- /dev/null
+++ b/package/lua-cqueues/lua-cqueues.mk
@@ -0,0 +1,23 @@
+################################################################################
+#
+# lua-cqueues
+#
+################################################################################
+
+LUA_CQUEUES_VERSION = rel-20161215
+LUA_CQUEUES_SITE = $(call github,wahern,cqueues,$(LUA_CQUEUES_VERSION))
+LUA_CQUEUES_LICENSE = MIT
+LUA_CQUEUES_LICENSE_FILES = LICENSE
+LUA_CQUEUES_DEPENDENCIES = luainterpreter openssl
+
+define LUA_CQUEUES_BUILD_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
+ prefix="$(STAGING_DIR)/usr" all$(LUAINTERPRETER_ABIVER)
+endef
+
+define LUA_CQUEUES_INSTALL_TARGET_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
+ DESTDIR="$(TARGET_DIR)" prefix=/usr install$(LUAINTERPRETER_ABIVER)
+endef
+
+$(eval $(generic-package))
OpenPOWER on IntegriCloud