summaryrefslogtreecommitdiffstats
path: root/package/linux-tools
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-03 22:56:08 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-05 01:28:45 +0200
commit0b8687d74b391caa05fbd92c1ab7ee26de55ade7 (patch)
tree76da5e916c3b19adc6f7e20a78d560b886d05567 /package/linux-tools
parentaa9a082a3df897ea1126cff24f86bc0214bc8f4d (diff)
downloadbuildroot-0b8687d74b391caa05fbd92c1ab7ee26de55ade7.tar.gz
buildroot-0b8687d74b391caa05fbd92c1ab7ee26de55ade7.zip
linux-tools: use the new gettext logic
This commit switches to use the new gettext logic, which involves: - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies on gettext/host-gettext - using TARGET_NLS_LIBS to force linking against libintl - dropping BR2_PACKAGE_GETTEXT selection. The BR2_USE_WCHAR dependency was only needed for gettext, so it is no longer needed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/linux-tools')
-rw-r--r--package/linux-tools/Config.in6
-rw-r--r--package/linux-tools/linux-tool-cpupower.mk4
2 files changed, 2 insertions, 8 deletions
diff --git a/package/linux-tools/Config.in b/package/linux-tools/Config.in
index db9ed9f19b..9d5bf7acc9 100644
--- a/package/linux-tools/Config.in
+++ b/package/linux-tools/Config.in
@@ -8,18 +8,12 @@ config BR2_PACKAGE_LINUX_TOOLS
config BR2_PACKAGE_LINUX_TOOLS_CPUPOWER
bool "cpupower"
depends on !BR2_bfin # pciutils
- depends on BR2_USE_WCHAR || !BR2_NEEDS_GETTEXT # gettext
select BR2_PACKAGE_LINUX_TOOLS
select BR2_PACKAGE_PCIUTILS
- select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
help
cpupower is a collection of tools to examine and tune power
saving related features of your processor.
-comment "cpupower needs a toolchain w/ wchar"
- depends on !BR2_bfin
- depends on !BR2_USE_WCHAR && BR2_NEEDS_GETTEXT
-
config BR2_PACKAGE_LINUX_TOOLS_GPIO
bool "gpio"
select BR2_PACKAGE_LINUX_TOOLS
diff --git a/package/linux-tools/linux-tool-cpupower.mk b/package/linux-tools/linux-tool-cpupower.mk
index 9958cff805..2a2d3e01dd 100644
--- a/package/linux-tools/linux-tool-cpupower.mk
+++ b/package/linux-tools/linux-tool-cpupower.mk
@@ -6,12 +6,12 @@
LINUX_TOOLS += cpupower
-CPUPOWER_DEPENDENCIES = pciutils $(if $(BR2_NEEDS_GETTEXT),gettext)
+CPUPOWER_DEPENDENCIES = pciutils $(TARGET_NLS_DEPENDENCIES)
CPUPOWER_MAKE_OPTS = CROSS=$(TARGET_CROSS) \
CPUFREQ_BENCH=false \
NLS=false \
- $(if $(BR2_NEEDS_GETTEXT),LDFLAGS=-lintl) \
+ LDFLAGS=$(TARGET_NLS_LIBS) \
DEBUG=false
define CPUPOWER_BUILD_CMDS
OpenPOWER on IntegriCloud