summaryrefslogtreecommitdiffstats
path: root/package/libxslt/libxslt.mk
diff options
context:
space:
mode:
authorJörg Krause <joerg.krause@embedded.rocks>2016-09-21 22:21:07 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-09-21 22:29:07 +0200
commit3d0ade55428a47a52656eec965dd7b8a81894073 (patch)
treef159c1e81d6d13feab6928ae23454f4b5929b90e /package/libxslt/libxslt.mk
parent0cd90001039c474319c00c0c0726f69816bc2188 (diff)
downloadbuildroot-3d0ade55428a47a52656eec965dd7b8a81894073.tar.gz
buildroot-3d0ade55428a47a52656eec965dd7b8a81894073.zip
package/libxslt: fix bfin compile
Fixes: http://autobuild.buildroot.org/results/df4/df4bf247c92847024dff88ce58a5f47343f06258/ http://autobuild.buildroot.org/results/b33/b33f34dc23f7429928d7d0b1478e71d8e7fffed2/ http://autobuild.buildroot.org/results/cad/cad02570ec039511b9495e82d98439e9f0724b37/ And many more. A GCC bug is triggered when the compiler is run with an optimization level '-Os/-O2/-O3' for the Blackfin architecture: ``` error: unable to find a register to spill in class 'CCREGS' ``` Workaround this bug by forcing an optimization level of '-O1' when building libxslt for the Blackfin architecture. See GCC bug report: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=77311 [Peter: add reference to autobuilders failures] Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libxslt/libxslt.mk')
-rw-r--r--package/libxslt/libxslt.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/libxslt/libxslt.mk b/package/libxslt/libxslt.mk
index 868ba6a10f..d89dde8d00 100644
--- a/package/libxslt/libxslt.mk
+++ b/package/libxslt/libxslt.mk
@@ -19,6 +19,12 @@ LIBXSLT_CONF_OPTS = \
LIBXSLT_CONFIG_SCRIPTS = xslt-config
LIBXSLT_DEPENDENCIES = libxml2
+# GCC bug with Os/O2/O3, PR77311
+# error: unable to find a register to spill in class 'CCREGS'
+ifeq ($(BR2_bfin),y)
+LIBXSLT_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -O1"
+endif
+
# If we have enabled libgcrypt then use it, else disable crypto support.
ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
LIBXSLT_DEPENDENCIES += libgcrypt
OpenPOWER on IntegriCloud