summaryrefslogtreecommitdiffstats
path: root/package/libxmlrpc/0004-use-correct-curl-config.patch
diff options
context:
space:
mode:
authorFabio Porcedda <fabio.porcedda@gmail.com>2015-02-27 10:19:19 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-02-27 17:18:38 +0100
commit5f91f5765ad174a801d3daefaa3e1ffa210293ea (patch)
treed96fa0a9d7484d18942ae15f335df1519414584e /package/libxmlrpc/0004-use-correct-curl-config.patch
parent9d13019edd0dd2f2c3c72adc61316f3621b9d831 (diff)
downloadbuildroot-5f91f5765ad174a801d3daefaa3e1ffa210293ea.tar.gz
buildroot-5f91f5765ad174a801d3daefaa3e1ffa210293ea.zip
libxmlrpc: add missing braces for variable CURL_CONFIG in patch 4
Change $CURL_CONFIG to $(CURL_CONFIG) in the patch 0004-use-correct-curl-config.patch because in a makefile the braces are required to expand a variable. Fix error messages: make[3]: Entering directory '/home/tetsuya/buildroot/br2/output/build/libxmlrpc-1.25.30/lib/curl_transport' make[3]: URL_CONFIG: Command not found /bin/sh: line 0: test: <: unary operator expected make[3]: URL_CONFIG: Command not found Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libxmlrpc/0004-use-correct-curl-config.patch')
-rw-r--r--package/libxmlrpc/0004-use-correct-curl-config.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/libxmlrpc/0004-use-correct-curl-config.patch b/package/libxmlrpc/0004-use-correct-curl-config.patch
index c0646d3b81..b5816432d8 100644
--- a/package/libxmlrpc/0004-use-correct-curl-config.patch
+++ b/package/libxmlrpc/0004-use-correct-curl-config.patch
@@ -55,7 +55,7 @@ Index: b/lib/curl_transport/Makefile
$(SRCDIR)/common.mk: srcdir blddir
-CURL_VERSION := $(shell curl-config --vernum)
-+CURL_VERSION := $(shell $CURL_CONFIG --vernum)
++CURL_VERSION := $(shell $(CURL_CONFIG) --vernum)
# Some time at or before Curl 7.12, <curl/types.h> became an empty file
# (no-op). Some time after Curl 7.18, <curl/types.h> ceased to exist.
@@ -64,7 +64,7 @@ Index: b/lib/curl_transport/Makefile
endif
-CURL_INCLUDES := $(shell curl-config --cflags)
-+CURL_INCLUDES := $(shell $CURL_CONFIG --cflags)
++CURL_INCLUDES := $(shell $(CURL_CONFIG) --cflags)
# We expect that curl-config --cflags just gives us -I options, because
# we need just the -I options for 'make dep'. Plus, it's scary to think
# of what any other compiler flag would do to our compile.
@@ -77,7 +77,7 @@ Index: b/src/cpp/test/Makefile
ifeq ($(MUST_BUILD_CURL_CLIENT),yes)
- LIBS += $(shell curl-config --libs)
-+ LIBS += $(shell $CURL_CONFIG --libs)
++ LIBS += $(shell $(CURL_CONFIG) --libs)
endif
ifeq ($(MUST_BUILD_LIBWWW_CLIENT),yes)
LIBS += $(shell libwww-config --libs)
@@ -90,7 +90,7 @@ Index: b/tools/common.mk
endif
ifeq ($(MUST_BUILD_CURL_CLIENT),yes)
- CLIENT_LDLIBS += $(shell curl-config --libs)
-+ CLIENT_LDLIBS += $(shell $CURL_CONFIG --libs)
++ CLIENT_LDLIBS += $(shell $(CURL_CONFIG) --libs)
endif
ifeq ($(MUST_BUILD_WININET_CLIENT),yes)
CLIENT_LDLIBS += $(shell wininet-config --libs)
OpenPOWER on IntegriCloud