summaryrefslogtreecommitdiffstats
path: root/package/libuio
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2016-07-02 11:00:06 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-07-02 13:26:33 +0200
commita728538c932a0626faf9371836fae49f9aa66c3d (patch)
tree7d5187d8ce8e1f7d1cd5ad06cff65c2ff0ce6e83 /package/libuio
parent1034c11efbc2c6a1c0aa2d5e60db3093e4ad4b0d (diff)
downloadbuildroot-a728538c932a0626faf9371836fae49f9aa66c3d.tar.gz
buildroot-a728538c932a0626faf9371836fae49f9aa66c3d.zip
package/libuio: fix build with external intl library
When intl library is not provided by the libc, libuio forgets to link with -lintl. Fixes: http://autobuild.buildroot.net/results/8f7/8f715b4e9b826dac13f3d49da25576e6e1d79449 [Peter: simplify using LIBUIO_LIBS as suggested by Yann] Signed-off-by: Romain Naour <romain.naour@smile.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libuio')
-rw-r--r--package/libuio/libuio.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/libuio/libuio.mk b/package/libuio/libuio.mk
index e019fe962d..ed842a9870 100644
--- a/package/libuio/libuio.mk
+++ b/package/libuio/libuio.mk
@@ -21,7 +21,16 @@ LIBUIO_CONF_ENV += MAKEINFO=true
ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
LIBUIO_DEPENDENCIES += argp-standalone
-LIBUIO_CONF_ENV += LIBS="-largp"
+LIBUIO_LIBS += -largp
endif
+# libuio pulls in libintl if needed, so ensure we also
+# link against it, otherwise static linking fails
+ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
+LIBUIO_DEPENDENCIES += gettext
+LIBUIO_LIBS += -lintl
+endif
+
+LIBUIO_CONF_ENV += LIBS="$(LIBUIO_LIBS)"
+
$(eval $(autotools-package))
OpenPOWER on IntegriCloud