summaryrefslogtreecommitdiffstats
path: root/package/libselinux
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2017-07-05 13:14:21 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-05 15:20:05 +0200
commit19ba17ee3ba946ac865849df89d7c2988ea5aca9 (patch)
treeab5ad66f2dff9a2f138c850ce7a3436d35bf95a3 /package/libselinux
parent1eb57df2b2eb965d58dc3d08a35238aa41af9e54 (diff)
downloadbuildroot-19ba17ee3ba946ac865849df89d7c2988ea5aca9.tar.gz
buildroot-19ba17ee3ba946ac865849df89d7c2988ea5aca9.zip
Globally replace $(HOST_DIR)/usr/lib with $(HOST_DIR)/lib
Since things are no longer installed in $(HOST_DIR)/usr, the callers should also not refer to it. This is a mechanical change with git grep -l '$(HOST_DIR)/usr/lib' | xargs sed -i 's%$(HOST_DIR)/usr/lib%$(HOST_DIR)/lib%g' Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libselinux')
-rw-r--r--package/libselinux/libselinux.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/libselinux/libselinux.mk b/package/libselinux/libselinux.mk
index 6362792201..d0aadf3892 100644
--- a/package/libselinux/libselinux.mk
+++ b/package/libselinux/libselinux.mk
@@ -89,7 +89,7 @@ HOST_LIBSELINUX_MAKE_OPTS = \
$(HOST_CONFIGURE_OPTS) \
LDFLAGS="$(HOST_LDFLAGS) -lpcre -lpthread" \
PYINC="$(HOST_LIBSELINUX_PYINC)" \
- PYSITEDIR="$(HOST_DIR)/usr/lib/$(HOST_LIBSELINUX_PYLIBVER)/site-packages" \
+ PYSITEDIR="$(HOST_DIR)/lib/$(HOST_LIBSELINUX_PYLIBVER)/site-packages" \
SWIG_LIB="$(HOST_DIR)/usr/share/swig/$(SWIG_VERSION)/"
define HOST_LIBSELINUX_BUILD_CMDS
@@ -97,7 +97,7 @@ define HOST_LIBSELINUX_BUILD_CMDS
# header paths.
$(HOST_MAKE_ENV) $(MAKE1) -C $(@D) \
$(HOST_LIBSELINUX_MAKE_OPTS) DESTDIR=$(HOST_DIR) \
- SHLIBDIR=$(HOST_DIR)/usr/lib all
+ SHLIBDIR=$(HOST_DIR)/lib all
# Generate python interface wrapper
$(HOST_MAKE_ENV) $(MAKE1) -C $(@D) \
$(HOST_LIBSELINUX_MAKE_OPTS) DESTDIR=$(HOST_DIR) swigify pywrap
@@ -106,8 +106,8 @@ endef
define HOST_LIBSELINUX_INSTALL_CMDS
$(HOST_MAKE_ENV) $(MAKE) -C $(@D) \
$(HOST_LIBSELINUX_MAKE_OPTS) DESTDIR=$(HOST_DIR) \
- SHLIBDIR=$(HOST_DIR)/usr/lib SBINDIR=$(HOST_DIR)/sbin install
- (cd $(HOST_DIR)/usr/lib; $(HOSTLN) -sf libselinux.so.1 libselinux.so)
+ SHLIBDIR=$(HOST_DIR)/lib SBINDIR=$(HOST_DIR)/sbin install
+ (cd $(HOST_DIR)/lib; $(HOSTLN) -sf libselinux.so.1 libselinux.so)
# Install python interface wrapper
$(HOST_MAKE_ENV) $(MAKE) -C $(@D) \
$(HOST_LIBSELINUX_MAKE_OPTS) DESTDIR=$(HOST_DIR) install-pywrap
OpenPOWER on IntegriCloud