summaryrefslogtreecommitdiffstats
path: root/package/libiio/libiio.mk
diff options
context:
space:
mode:
authorPaul Cercueil <paul.cercueil@analog.com>2016-07-05 12:27:28 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-05 17:20:52 +0200
commit00deb6a7c11440766767cc07800661e8067df474 (patch)
tree2d7bd465d3b36f8f018d7c74b92c0dc040be2a0e /package/libiio/libiio.mk
parent784d49c2d3f4b000e2805ca808e99d399ea251f4 (diff)
downloadbuildroot-00deb6a7c11440766767cc07800661e8067df474.tar.gz
buildroot-00deb6a7c11440766767cc07800661e8067df474.zip
libiio: Bump version to 0.7
The two previous patches have been merged upstream, so they have been deleted here. Another patch (picked from upstream) has been added to fix the build with thread-less toolchains. Libiio v0.7 provides two new backends, a USB backend (using libusb-1.0) and a serial backend (using libserialport). Additionally, it is now possible to compile libiio with thread-less toolchains. In that case, thread safety is disabled. Signed-off-by: Paul Cercueil <paul.cercueil@analog.com> Reviewed-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libiio/libiio.mk')
-rw-r--r--package/libiio/libiio.mk23
1 files changed, 19 insertions, 4 deletions
diff --git a/package/libiio/libiio.mk b/package/libiio/libiio.mk
index 6479e6f806..3cbfdd63f9 100644
--- a/package/libiio/libiio.mk
+++ b/package/libiio/libiio.mk
@@ -4,7 +4,7 @@
#
################################################################################
-LIBIIO_VERSION = 0.6
+LIBIIO_VERSION = 0.7
LIBIIO_SITE = $(call github,analogdevicesinc,libiio,v$(LIBIIO_VERSION))
LIBIIO_INSTALL_STAGING = YES
LIBIIO_LICENSE = LGPLv2.1+
@@ -12,14 +12,29 @@ LIBIIO_LICENSE_FILES = COPYING.txt
LIBIIO_CONF_OPTS = -DENABLE_IPV6=ON \
-DWITH_LOCAL_BACKEND=$(if $(BR2_PACKAGE_LIBIIO_LOCAL_BACKEND),ON,OFF) \
+ -DWITH_NETWORK_BACKEND=$(if $(BR2_PACKAGE_LIBIIO_NETWORK_BACKEND),ON,OFF) \
-DWITH_TESTS=$(if $(BR2_PACKAGE_LIBIIO_TESTS),ON,OFF) \
-DWITH_DOC=OFF
-ifeq ($(BR2_PACKAGE_LIBIIO_NETWORK_BACKEND),y)
+ifeq ($(BR2_PACKAGE_LIBIIO_XML_BACKEND),y)
LIBIIO_DEPENDENCIES += libxml2
-LIBIIO_CONF_OPTS += -DWITH_NETWORK_BACKEND=ON
+LIBIIO_CONF_OPTS += -DWITH_XML_BACKEND=ON
else
-LIBIIO_CONF_OPTS += -DWITH_NETWORK_BACKEND=OFF
+LIBIIO_CONF_OPTS += -DWITH_XML_BACKEND=OFF
+endif
+
+ifeq ($(BR2_PACKAGE_LIBIIO_USB_BACKEND),y)
+LIBIIO_DEPENDENCIES += libusb
+LIBIIO_CONF_OPTS += -DWITH_USB_BACKEND=ON
+else
+LIBIIO_CONF_OPTS += -DWITH_USB_BACKEND=OFF
+endif
+
+ifeq ($(BR2_PACKAGE_LIBIIO_SERIAL_BACKEND),y)
+LIBIIO_DEPENDENCIES += libserialport
+LIBIIO_CONF_OPTS += -DWITH_SERIAL_BACKEND=ON
+else
+LIBIIO_CONF_OPTS += -DWITH_SERIAL_BACKEND=OFF
endif
ifeq ($(BR2_PACKAGE_LIBIIO_IIOD),y)
OpenPOWER on IntegriCloud