summaryrefslogtreecommitdiffstats
path: root/package/libgdiplus
diff options
context:
space:
mode:
authorSergio Prado <sergio.prado@e-labworks.com>2015-11-24 22:15:10 -0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-17 22:28:05 +0100
commit326b0f37d571e78f36e41b50f8b508ce3842ccda (patch)
tree101d8328d655120461797057f5d67ac86218e108 /package/libgdiplus
parent37e7c34aaf74d6115ccfbc0fb233d3e8b016b6fc (diff)
downloadbuildroot-326b0f37d571e78f36e41b50f8b508ce3842ccda.tar.gz
buildroot-326b0f37d571e78f36e41b50f8b508ce3842ccda.zip
libgdiplus: new package
Libgdiplus is an open source implementation of the GDI+ API. [Thomas: remove trailing whitespace.] Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libgdiplus')
-rw-r--r--package/libgdiplus/Config.in21
-rw-r--r--package/libgdiplus/libgdiplus.hash2
-rw-r--r--package/libgdiplus/libgdiplus.mk56
3 files changed, 79 insertions, 0 deletions
diff --git a/package/libgdiplus/Config.in b/package/libgdiplus/Config.in
new file mode 100644
index 0000000000..f860ab3394
--- /dev/null
+++ b/package/libgdiplus/Config.in
@@ -0,0 +1,21 @@
+config BR2_PACKAGE_LIBGDIPLUS
+ bool "libgdiplus"
+ select BR2_PACKAGE_XLIB_LIBXFT
+ select BR2_PACKAGE_LIBGLIB2
+ select BR2_PACKAGE_CAIRO
+ select BR2_PACKAGE_LIBPNG
+ depends on BR2_PACKAGE_XORG7
+ depends on BR2_USE_WCHAR # libglib2 -> gettext
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+ depends on BR2_USE_MMU # libglib2
+ depends on BR2_ARCH_HAS_ATOMICS # cairo
+ help
+ An Open Source implementation of the GDI+ API.
+
+ https://github.com/mono/libgdiplus
+
+comment "libgdiplus needs a toolchain w/ wchar, threads"
+ depends on BR2_USE_MMU
+ depends on BR2_ARCH_HAS_ATOMICS
+ depends on BR2_PACKAGE_XORG7
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libgdiplus/libgdiplus.hash b/package/libgdiplus/libgdiplus.hash
new file mode 100644
index 0000000000..71ffdd3466
--- /dev/null
+++ b/package/libgdiplus/libgdiplus.hash
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256 7eadc5105c6352d456c5f8699dc89260bf402e82ce6668e7e0c625519f9e5b44 libgdiplus-3.12.tar.gz
diff --git a/package/libgdiplus/libgdiplus.mk b/package/libgdiplus/libgdiplus.mk
new file mode 100644
index 0000000000..3f7b2d7017
--- /dev/null
+++ b/package/libgdiplus/libgdiplus.mk
@@ -0,0 +1,56 @@
+################################################################################
+#
+# libgdiplus
+#
+################################################################################
+
+LIBGDIPLUS_VERSION = 3.12
+LIBGDIPLUS_SITE = $(call github,mono,libgdiplus,$(LIBGDIPLUS_VERSION))
+
+# Although there is a LICENSE file thas specifies LGPL or MPLv1.1,
+# looks like it is incorrect. The actual source files specify that
+# they're licensed under MIT, and so does the COPYING file (and they
+# all predate the addition of the LICENSE file).
+LIBGDIPLUS_LICENSE = MIT
+LIBGDIPLUS_LICENSE_FILES = COPYING src/carbon-private.h
+
+LIBGDIPLUS_INSTALL_STAGING = YES
+
+# github tarball doesn't have configure
+LIBGDIPLUS_AUTORECONF = YES
+
+LIBGDIPLUS_DEPENDENCIES = xlib_libXft libglib2 cairo libpng host-pkgconf
+
+# API changes in recent versions of libgif makes it incompatible with
+# this version of libgdiplus, so we are disabling it for now.
+LIBGDIPLUS_CONF_OPTS = --without-libgif
+
+# there is a bug in the configure script that enables pango support
+# when passing --without-pango, so let's just not use it
+ifeq ($(BR2_PACKAGE_PANGO),y)
+LIBGDIPLUS_CONF_OPTS += --with-pango
+LIBGDIPLUS_DEPENDENCIES += pango
+endif
+
+ifeq ($(BR2_PACKAGE_LIBEXIF),y)
+LIBGDIPLUS_CONF_OPTS += --with-libexif
+LIBGDIPLUS_DEPENDENCIES += libexif
+else
+LIBGDIPLUS_CONF_OPTS += --without-libexif
+endif
+
+ifeq ($(BR2_PACKAGE_JPEG),y)
+LIBGDIPLUS_CONF_OPTS += --with-libjpeg
+LIBGDIPLUS_DEPENDENCIES += jpeg
+else
+LIBGDIPLUS_CONF_OPTS += --without-libjpeg
+endif
+
+ifeq ($(BR2_PACKAGE_TIFF),y)
+LIBGDIPLUS_CONF_OPTS += --with-libtiff
+LIBGDIPLUS_DEPENDENCIES += tiff
+else
+LIBGDIPLUS_CONF_OPTS += --without-libtiff
+endif
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud