summaryrefslogtreecommitdiffstats
path: root/package/libcurl
diff options
context:
space:
mode:
authorRyan Barnett <rjbarnet@rockwellcollins.com>2013-08-30 09:09:45 -0500
committerPeter Korsgaard <jacmet@sunsite.dk>2013-09-08 21:53:11 +0200
commitd45db95633ed2e73d97a9de911ab5f0c063defaf (patch)
tree060a8a916a1c543c26a457532f6a40d96769d5f1 /package/libcurl
parent2ee180e3e2a4ddfabae9d1acdcb6b418d2174ea6 (diff)
downloadbuildroot-d45db95633ed2e73d97a9de911ab5f0c063defaf.tar.gz
buildroot-d45db95633ed2e73d97a9de911ab5f0c063defaf.zip
libcurl: add support for compiling with libssh2
Adding configuration options that if libssh2 is selected, compile libcurl with --with-ssh config flag. Signed-off-by: Ryan Barnett <rjbarnet@rockwellcollins.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libcurl')
-rw-r--r--package/libcurl/libcurl.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/libcurl/libcurl.mk b/package/libcurl/libcurl.mk
index 71f19f19c3..059f08a119 100644
--- a/package/libcurl/libcurl.mk
+++ b/package/libcurl/libcurl.mk
@@ -47,6 +47,14 @@ LIBCURL_CONF_OPT += --without-ssl --without-gnutls \
--without-polarssl --without-nss
endif
+# Configure curl to support libssh2
+ifeq ($(BR2_PACKAGE_LIBSSH2),y)
+LIBCURL_DEPENDENCIES += libssh2
+LIBCURL_CONF_OPT += --with-libssh2
+else
+LIBCURL_CONF_OPT += --without-libssh2
+endif
+
define LIBCURL_FIX_DOT_PC
printf 'Requires: openssl\n' >>$(@D)/libcurl.pc.in
endef
OpenPOWER on IntegriCloud