summaryrefslogtreecommitdiffstats
path: root/package/kodi
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2015-10-20 21:42:26 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-10-20 22:03:31 +0200
commit62ce7751b46eb609f13582352a6d6f11559819c4 (patch)
tree5c6fcacee2b593911fe3eb0277cd88bebd56b88d /package/kodi
parentf1c94ed0a8109d7897bb3a49a317daade23c3d51 (diff)
downloadbuildroot-62ce7751b46eb609f13582352a6d6f11559819c4.tar.gz
buildroot-62ce7751b46eb609f13582352a6d6f11559819c4.zip
package/kodi: Add support for libssh
This patch depends on http://patchwork.ozlabs.org/patch/512480/ and adds sftp support to the virtual filesystems supported by Kodi. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/kodi')
-rw-r--r--package/kodi/Config.in6
-rw-r--r--package/kodi/kodi.mk8
2 files changed, 13 insertions, 1 deletions
diff --git a/package/kodi/Config.in b/package/kodi/Config.in
index eede24328d..9d3ea6f591 100644
--- a/package/kodi/Config.in
+++ b/package/kodi/Config.in
@@ -218,6 +218,12 @@ config BR2_PACKAGE_KODI_LIBSMBCLIENT
help
Enable Samba support
+config BR2_PACKAGE_KODI_LIBSSH
+ bool "ssh"
+ select BR2_PACKAGE_LIBSSH
+ help
+ Enable sftp virtual filesystem using libssh.
+
config BR2_PACKAGE_KODI_LIBTHEORA
bool "theora"
select BR2_PACKAGE_LIBTHEORA
diff --git a/package/kodi/kodi.mk b/package/kodi/kodi.mk
index 24c5e5a21c..46d8650c9a 100644
--- a/package/kodi/kodi.mk
+++ b/package/kodi/kodi.mk
@@ -34,7 +34,6 @@ KODI_CONF_OPTS += \
--disable-openmax \
--disable-projectm \
--disable-pulse \
- --disable-ssh \
--disable-vdpau \
--disable-vtbdecoder \
--enable-optimizations
@@ -172,6 +171,13 @@ else
KODI_CONF_OPTS += --disable-airplay
endif
+ifeq ($(BR2_PACKAGE_KODI_LIBSSH),y)
+KODI_DEPENDENCIES += libssh
+KODI_CONF_OPTS += --enable-ssh
+else
+KODI_CONF_OPTS += --disable-ssh
+endif
+
ifeq ($(BR2_PACKAGE_KODI_AVAHI),y)
KODI_DEPENDENCIES += avahi
KODI_CONF_OPTS += --enable-avahi
OpenPOWER on IntegriCloud