summaryrefslogtreecommitdiffstats
path: root/package/kodi/kodi.mk
diff options
context:
space:
mode:
authorDagg Stompler <daggs@gmx.com>2016-11-09 21:07:33 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-09 22:50:12 +0100
commit00e7d119ec16cd64f89cb21a2ea715e2bfc3dc73 (patch)
treedd4bb59d8ee29fe376396bf298b64206efd822f7 /package/kodi/kodi.mk
parent8f4c905adf76d49c33ba29f090a149a6128b64cb (diff)
downloadbuildroot-00e7d119ec16cd64f89cb21a2ea715e2bfc3dc73.tar.gz
buildroot-00e7d119ec16cd64f89cb21a2ea715e2bfc3dc73.zip
kodi: allow enablement of libamcodec as codec if selected
allow usage of amcodec if kodi is built and libamcodec is selected Signed-off-by: Dagg Stompler <daggs@gmx.com> [Thomas: fix KODI_INCLUDES definition in RPi case, fix indentation.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/kodi/kodi.mk')
-rw-r--r--package/kodi/kodi.mk17
1 files changed, 14 insertions, 3 deletions
diff --git a/package/kodi/kodi.mk b/package/kodi/kodi.mk
index e0361dae78..de4d308f6b 100644
--- a/package/kodi/kodi.mk
+++ b/package/kodi/kodi.mk
@@ -96,9 +96,10 @@ endif
ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
KODI_DEPENDENCIES += rpi-userland
KODI_CONF_OPTS += --with-platform=raspberry-pi --enable-player=omxplayer
-KODI_CONF_ENV += INCLUDES="-I$(STAGING_DIR)/usr/include/interface/vcos/pthreads \
- -I$(STAGING_DIR)/usr/include/interface/vmcs_host/linux" \
- LIBS="-lvcos -lvchostif"
+KODI_INCLUDES += \
+ -I$(STAGING_DIR)/usr/include/interface/vcos/pthreads \
+ -I$(STAGING_DIR)/usr/include/interface/vmcs_host/linux
+KODI_LIBS = -lvcos -lvchostif
endif
ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
@@ -113,6 +114,16 @@ KODI_DEPENDENCIES += imx-vpuwrap
KODI_CONF_OPTS += --enable-codec=imxvpu
endif
+ifeq ($(BR2_PACKAGE_LIBAMCODEC),y)
+KODI_DEPENDENCIES += libamcodec
+KODI_CONF_OPTS += --enable-codec=amcodec
+KODI_INCLUDES += -I$(STAGING_DIR)/usr/include/amcodec
+endif
+
+KODI_CONF_ENV += \
+ INCLUDES="$(KODI_INCLUDES)" \
+ LIBS="$(KODI_LIBS)"
+
ifeq ($(BR2_PACKAGE_LIBCAP),y)
KODI_CONF_OPTS += --enable-libcap
KODI_DEPENDENCIES += libcap
OpenPOWER on IntegriCloud