summaryrefslogtreecommitdiffstats
path: root/package/kmsxx
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-08-05 20:05:00 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-08-05 20:59:42 +0200
commitcd183755ffed03107df1e58b948e3d99b167c5e3 (patch)
tree480bed3c8161cbb8696c337eee693834b71c229d /package/kmsxx
parent5879f0192e99982880aeff7da5bb934b202a6262 (diff)
downloadbuildroot-cd183755ffed03107df1e58b948e3d99b167c5e3.tar.gz
buildroot-cd183755ffed03107df1e58b948e3d99b167c5e3.zip
package/kmsxx: detect failure at install-staging
Currently, the staging-install commands do not detect failures to install the libs. That's because we use ';' to separate the commands, so we only get the result of the last one. Fix that by using multi-line commands, so they each are called on their own and make would catch the failures. Partially fixes (only detects the real failure): http://autobuild.buildroot.org/results/82c/82cfb7451f933b222abe30b5d35d23e409a4af79 and a few others. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Maxime Ripard <maxime.ripard@free-electrons.com> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/kmsxx')
-rw-r--r--package/kmsxx/kmsxx.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kmsxx/kmsxx.mk b/package/kmsxx/kmsxx.mk
index d49ec8fe7d..84c860c4a1 100644
--- a/package/kmsxx/kmsxx.mk
+++ b/package/kmsxx/kmsxx.mk
@@ -39,8 +39,8 @@ endef
define KMSXX_INSTALL_STAGING_CMDS
$(foreach l,$(KMSXX_LIBS),\
$(INSTALL) -D -m 0755 $(@D)/lib/lib$(l).so \
- $(STAGING_DIR)/usr/lib/lib$(l).so ; \
- mkdir -p $(STAGING_DIR)/usr/include/$(l) ; \
+ $(STAGING_DIR)/usr/lib/lib$(l).so
+ mkdir -p $(STAGING_DIR)/usr/include/$(l)
cp -dpfr $(@D)/$(l)/inc/$(l)/* $(STAGING_DIR)/usr/include/$(l)/
)
endef
OpenPOWER on IntegriCloud