summaryrefslogtreecommitdiffstats
path: root/package/i7z/i7z.mk
diff options
context:
space:
mode:
authorVincent Stehlé <vincent.stehle@intel.com>2016-04-27 15:12:44 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-04-27 22:08:11 +0200
commite891482f2ac671e55f15679580d14b5c51136f2e (patch)
tree38cb96fc0c2babad260e75a3a3cca82ffc2ba9e2 /package/i7z/i7z.mk
parent7e40766473e8ebf5ad342ebc94f018c0e22d4fb8 (diff)
downloadbuildroot-e891482f2ac671e55f15679580d14b5c51136f2e.tar.gz
buildroot-e891482f2ac671e55f15679580d14b5c51136f2e.zip
i7z: new package
"A better i7 (and now i3, i5) reporting tool for Linux." i7z can print out the C-states and temperature for i3, i5 and i7 based Core processors from Intel (including Nehalems, Sandy Bridge and Ivy Bridge). https://github.com/ajaiantilal/i7z Signed-off-by: Vincent Stehlé <vincent.stehle@intel.com> Cc: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/i7z/i7z.mk')
-rw-r--r--package/i7z/i7z.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/i7z/i7z.mk b/package/i7z/i7z.mk
new file mode 100644
index 0000000000..e21fd9fba1
--- /dev/null
+++ b/package/i7z/i7z.mk
@@ -0,0 +1,22 @@
+################################################################################
+#
+# i7z
+#
+################################################################################
+
+I7Z_VERSION = 5023138d7c35c4667c938b853e5ea89737334e92
+I7Z_SITE = $(call github,ajaiantilal,i7z,$(I7Z_VERSION))
+I7Z_LICENSE = GPLv2
+I7Z_LICENSE_FILES = COPYING
+I7Z_DEPENDENCIES = ncurses
+
+define I7Z_BUILD_CMDS
+ $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+define I7Z_INSTALL_TARGET_CMDS
+ $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) install \
+ DESTDIR="$(TARGET_DIR)"
+endef
+
+$(eval $(generic-package))
OpenPOWER on IntegriCloud