summaryrefslogtreecommitdiffstats
path: root/package/heimdal/heimdal.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-03-02 09:42:16 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-02 15:20:31 +0100
commit56258f491bf459cbdb2cee1db3267030340755f0 (patch)
tree154041f4e970479f0e82932874ca36e9fd55a91e /package/heimdal/heimdal.mk
parent88680c5bf9110fafd0f76f44cc615b189029374b (diff)
downloadbuildroot-56258f491bf459cbdb2cee1db3267030340755f0.tar.gz
buildroot-56258f491bf459cbdb2cee1db3267030340755f0.zip
heimdal: new package
host-heimdal is required for samba 4.1.x since it can't (yet) link with an external heimdal implementation and can't cross-compile the internal tools. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/heimdal/heimdal.mk')
-rw-r--r--package/heimdal/heimdal.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/heimdal/heimdal.mk b/package/heimdal/heimdal.mk
new file mode 100644
index 0000000000..c73b33ed88
--- /dev/null
+++ b/package/heimdal/heimdal.mk
@@ -0,0 +1,30 @@
+################################################################################
+#
+# heimdal
+#
+################################################################################
+
+HEIMDAL_VERSION = 1.5.3
+HEIMDAL_SITE = http://www.h5l.org/dist/src
+HEIMDAL_DEPENDENCIES = host-e2fsprogs host-pkgconf
+HEIMDAL_INSTALL_STAGING = YES
+# static because of -fPIC issues with e2fsprogs on x86_64 host
+HOST_HEIMDAL_CONF_OPT = --with-x=no --disable-shared --enable-static
+HOST_HEIMDAL_CONF_ENV = MAKEINFO=true
+HEIMDAL_MAKE = $(MAKE1)
+# For heimdal-0004-compile_et.patch
+HEIMDAL_AUTORECONF = YES
+HEIMDAL_LICENSE = BSD-3c
+HEIMDAL_LICENSE_FILES = LICENSE
+
+# We need asn1_compile in the PATH for samba4
+define HOST_HEIMDAL_MAKE_SYMLINK
+ ln -sf $(HOST_DIR)/usr/libexec/heimdal/asn1_compile \
+ $(HOST_DIR)/usr/bin/asn1_compile
+ ln -sf $(HOST_DIR)/usr/bin/compile_et \
+ $(HOST_DIR)/usr/libexec/heimdal/compile_et
+endef
+
+HOST_HEIMDAL_POST_INSTALL_HOOKS += HOST_HEIMDAL_MAKE_SYMLINK
+
+$(eval $(host-autotools-package))
OpenPOWER on IntegriCloud