summaryrefslogtreecommitdiffstats
path: root/package/hans
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2015-02-21 09:45:12 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-21 15:26:01 +0100
commit5f29f8663db43fbcdbf981e87f6d37b1932bc2ed (patch)
tree4bc56f7fc870fbf26b8949b91893f9b870defc50 /package/hans
parent631b09645a61641531949e4772bebf20ea1154ce (diff)
downloadbuildroot-5f29f8663db43fbcdbf981e87f6d37b1932bc2ed.tar.gz
buildroot-5f29f8663db43fbcdbf981e87f6d37b1932bc2ed.zip
hans: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/hans')
-rw-r--r--package/hans/Config.in13
-rw-r--r--package/hans/hans.hash3
-rw-r--r--package/hans/hans.mk20
3 files changed, 36 insertions, 0 deletions
diff --git a/package/hans/Config.in b/package/hans/Config.in
new file mode 100644
index 0000000000..7b60090f62
--- /dev/null
+++ b/package/hans/Config.in
@@ -0,0 +1,13 @@
+comment "hans needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP
+
+config BR2_PACKAGE_HANS
+ bool "hans"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ Hans makes it possible to tunnel IPv4 through ICMP echo packets,
+ so you could call it a ping tunnel.
+ This can be useful when you find yourself in the situation
+ that your Internet access is firewalled, but pings are allowed.
+
+ http://code.gerade.org/hans/
diff --git a/package/hans/hans.hash b/package/hans/hans.hash
new file mode 100644
index 0000000000..c1a28df129
--- /dev/null
+++ b/package/hans/hans.hash
@@ -0,0 +1,3 @@
+# From http://sourceforge.net/projects/hanstunnel/files/source/
+md5 97a93a886bc766212257198fd99d1061 hans-0.4.4.tar.gz
+sha1 8a21a9acc6d52cf7d2a5049523469e2609716ab3 hans-0.4.4.tar.gz
diff --git a/package/hans/hans.mk b/package/hans/hans.mk
new file mode 100644
index 0000000000..bda091f33a
--- /dev/null
+++ b/package/hans/hans.mk
@@ -0,0 +1,20 @@
+################################################################################
+#
+# hans
+#
+################################################################################
+
+HANS_VERSION = 0.4.4
+HANS_SITE = http://downloads.sourceforge.net/project/hanstunnel/source
+HANS_LICENSE = GPLv3+
+HANS_LICENSE_FILES = LICENSE
+
+define HANS_BUILD_CMDS
+ $(MAKE) GCC="$(TARGET_CC)" GPP="$(TARGET_CXX)" -C $(@D)
+endef
+
+define HANS_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 755 -D $(@D)/hans $(TARGET_DIR)/usr/sbin/hans
+endef
+
+$(eval $(generic-package))
OpenPOWER on IntegriCloud