summaryrefslogtreecommitdiffstats
path: root/package/gtest
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2014-01-24 16:24:24 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-01-26 21:58:45 +0100
commit34924f620d7151d8f1d4f5561c754cdd63ab10b5 (patch)
tree2f54a18e37bb199025511832fe97cfbbfaf5203e /package/gtest
parentf873de877d63b7d4d7e670bfcc18c1b5fe55906a (diff)
downloadbuildroot-34924f620d7151d8f1d4f5561c754cdd63ab10b5.tar.gz
buildroot-34924f620d7151d8f1d4f5561c754cdd63ab10b5.zip
gtest: force static library build
While it seems possible to build gtest as a shared library, using it in other projects requires to set some specific configuration flags in these projects for correctly linking against the shared version of the gtest library. So, to avoid bothering many projects and keep things as they were so far, we just force gtest to be built as a static library. Fixes: http://autobuild.buildroot.net/results/20cbf90749672607cb277c676a45d2c0c3965fa0/ http://autobuild.buildroot.net/results/5c6e58c51b2a14a7f23d296f771a76096b80362a/ http://autobuild.buildroot.net/results/bde777d343e9c4884272893d0da3b113dcc75e3a/ http://autobuild.buildroot.net/results/20cbf90749672607cb277c676a45d2c0c3965fa0/ http://autobuild.buildroot.net/results/89a29d1f597dbc12a6fc8eb079133a84952fc612/ Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gtest')
-rw-r--r--package/gtest/gtest.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/gtest/gtest.mk b/package/gtest/gtest.mk
index e661d734c1..c7b2cf035b 100644
--- a/package/gtest/gtest.mk
+++ b/package/gtest/gtest.mk
@@ -12,6 +12,15 @@ GTEST_INSTALL_TARGET = NO
GTEST_LICENSE = BSD-3c
GTEST_LICENSE_FILES = LICENSE
+# While it is possible to build gtest as shared library, using this gtest shared
+# library requires to set some special configure option in the project using
+# gtest.
+# So, force to build gtest as a static library.
+#
+# For further details, refer to the explaination given in the README file from
+# the gtest sources.
+GTEST_CONF_OPT = -DBUILD_SHARED_LIBS=OFF
+
define GTEST_EXTRACT_CMDS
unzip $(DL_DIR)/$(GTEST_SOURCE) -d $(BUILD_DIR)
endef
OpenPOWER on IntegriCloud